Jump to content
Mumble forums

Debugging overlay


pavelhoral
 Share

Recommended Posts

Hello,


I am testing Mumble 1.2.3-rc1-4 and I can not get the overlay to work (testing with Battlefield 2 modification called Project Reality).

With the old Mumble 1.2.2 everything worked fine. With the new version nothing is displayed in the game. Is there a way how to check what is wrong or how to get some additional debugging information (e.g. if there is something in dxdiag to check)? I did not want to create bug report without being sure it is a bug.


Thank you,

Pavel

Link to comment
Share on other sites

  • Administrators

You could ask on IRC if you want direct contact …


Anyway,

did you try installing 1.2.2 and check again that it is indeed still the case that on the same system, drivers and gameversion where an update to 1.2.3rc1 makes the overlay not display anymore?


Did you check that you’re using blacklist-overlay exceptions and not whitelist in Mumbles overlay settings?


Is it only Bf?


System? Drivers? Version (driver & game)? Which dx version does that game use?

Link to comment
Share on other sites

Not trying to hijack Pavel's post, but I have not been able to get the overlay working at all. 2 squad mates have and they are using Nvidia cards where I have 2 HD5770 cards. I thought I read somewhere that the overlay is not compatible with DX11... is that the issue?


Oh yeah... we are playing BFBC2 on Win7 rigs and they are using 1.2.2 and I have 1.2.3 rc, but I could not get it to work even when I had 1.2.2

Link to comment
Share on other sites

It magically starts to work! What I did is:

 

  1. I wanted to test the overlay in the simplest possible application - VLC player.
  2. I knew it is blacklisted by default, so I opened Mumble settings and removed the vlc.exe entry.
  3. Then I started the player and nothing happened.
  4. I've read (in some bug report from kissaki) that for blacklist/whitelist changes to take the effect the application needs to be restarted (might be nice if the application will tell you this).
  5. I've restarted Mumble and started VLC player again. And it works perfectly!
  6. Then I started Battlefield 2 and... here comes magic - it works as well.

 

So what have happened? There is only one possible explanation*: Mumble changed something after tampering with the blacklist!. If this is the case, then its definetely a bug. Before reporting the bug I want to be able to reproduce it. Two ways:

 

  1. Someone with the same problem will do the same procedure as described above and write to this thread.
  2. Someone can tell me where the blacklist is stored and how can I get Mumble to the state before tampering with the blacklist configuration.

 

Thank you for any help,

Pavel


* The possibility that the error was between the keyboard and the chair is very unprobable. I am a technical person and I played with the overlay configuration for almost two hours (unfortunatelly not touching the blacklist).

Link to comment
Share on other sites

  • Administrators

The overlay settings are stored, like all settings, in the windows registry by default.

In portable mode they are stored in the Murmur.ini, but the overlay-lists (black/white) are still read from registry by the overlay (not by the client Mumble itself though).

HKEY_CURRENT_USER\Software\Mumble\Mumble

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...