Jump to content
Mumble forums

SSL certificate accepted only for root user


sfievet
 Share

Recommended Posts

Hi,


my mumble client refuses to connect to any server when launched as normal user. It loops on the certificate acceptation pop-up window. When i click "accept", it disconnects, then reconnect and re-ask... Forever. If i launch mumble as root, it only ask once, then connect to the server. My guess is that it may be access rights related, but where?


My config :

- distro : linux from scratch 6.2

- mumble : 1.2.2 compiled from source

- Qt : 4.4.3 (also tried 4.5.3, and 4.6.3 with no luck)

- Openssl 0.9.8q

- kernel : 2.6.35.8

- soundcard : Realtek ALC 850

- alsa driver : snd-intel8x0 v1.0.23


Please help!

Link to comment
Share on other sites

Run mumble from an Terminal/Console to see the warnings and other information. The output can be quite long when you log into a server with a large number of channels, but as you are not able to login this should not be a problem.

Computer specs: AMD FX-8320, 8GB DDR3-SDRAM, AMD Radeon HD 7950, Asus Xonar D1, Windows 7 Ultimate 64bit/Debian Jessie AMD64.

Link to comment
Share on other sites

:D

Thanks pcgod! You pointed me to the right direction :

the database which stores accepted SSL certs is in ~/.local/share/Mumble/Mumble

Actually it's in .local/share/data/Mumble/Mumble. I removed the ".mumble.sqlite" file within, and re-started mumble.

...And it worked. The file must have been corrupted i don't know how.


thanks again,

Seb.


@ rawnar : i tried it countless times, but mumble is not exactly verbose (even the debug build), and it didn't give me any clues... But thank you anyways.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...