Jump to content
Mumble forums

Notifications like channel movement plays out of speakers


losse1
 Share

Recommended Posts

Under Windows the Speech API (SAPI) is used to synthesis the text to speech. Within mumble there are no options to change the output of this system, so it will use the default output. I do not know if you can set the default output for SAPI in windows but you can select you headphones as the default playback speakers in windows.


Under Linux the program speech-dispatcher is used. To change the behavior of this program take a look at /etc/speech-dispatcher/speechd.conf and this


Under MAC OSX the Speech Synthesis Manager is used. As I do not own a MAC I do not have any idea how to change its output.


Update: Had a quick look on my win 7 setup. You can set the output device for the Text to Speech via the configuration screen. I am running a dutch version of windows, so I need to do some loose translations into English. Go to windows configuration screen click on "speech recognition". In the new window there is a link to "text to speech" click on it. The new dialog will show the setting for "text to speech", under the advanced button there is an option to select the output device without changing the standard output device of windows. If you can not find the dialog try to search for "text to speech" with the search option in the start menu.

Computer specs: AMD FX-8320, 8GB DDR3-SDRAM, AMD Radeon HD 7950, Asus Xonar D1, Windows 7 Ultimate 64bit/Debian Jessie AMD64.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...