Jump to content
Mumble forums

After Server(Ubuntu) Start, or Restart Murmur didnt start


chris789
 Share

Recommended Posts

Hello all,

i have a Problem with the new Murmur Server 1.2.3 stable.


mumble-server.log

2011-02-24 00:07:11.559 Initializing settings from /etc/mumble-server.ini (basepath /etc)

2011-02-24 00:07:11.559 OpenSSL: OpenSSL 0.9.8o 01 Jun 2010

2011-02-24 00:07:11.575 SSL: Adding recommended CA UTN-USERFirst-Client Authentication and Email

2011-02-24 00:07:11.577 ServerDB: Openend SQLite database /var/lib/mumble-server/mumble-server.sqlite

2011-02-24 00:07:11.586 DBus registration succeeded

2011-02-24 00:07:11.603 MurmurIce: Endpoint "tcp -h 127.0.0.1 -p 6502" running

2011-02-24 00:07:11.651 Murmur 1.2.3 (1.2.3-1~ppa1~maverick1) running on X11: Ubuntu 10.10: Booting servers

2011-02-24 00:07:11.869 1 => Announcing server via bonjour

2011-02-24 00:07:11.943 1 => Registration needs nonempty 'registername', 'registerpassword' and 'registerurl', must have an empty 'password' and allowed pings.

 

Nothing more. Cant connect to the Server. Refused. :-(

After "service mumble-server restart" it works perfect. Everytime i start/restart the Ubuntu Server i need a manually Mumble restart.

The old Version 1.2.2 worked.


I use the 64Bit Version of Ubuntu 10.10 Server. A fresh install of Ubuntu.


Thanks

chris

Edited by chris789
Link to comment
Share on other sites

Is the server running at all after you boot? Just to be clear, this is the log after boot but BEFORE you start the server by hand?

You can do a:

netstat -tnap | grep murmur

See if you see is you get anything, it will show what port the server is listening on as well. If you get nothing back from that it means that the server is not listening on any ports.



You can also check to see if the server is running at all:

ps aux | grep [m]urmur

 

On my server log I get a line in my mumble-server.log that says:

1 => Server listening on [::]:64738

Right before the Announcing server vi bonjour line. That line tells you what port the server is listening on, I find it odd that your server is not saying that.

Link to comment
Share on other sites

Hello delset,


thanks for your reply.

I try your Commands.

 

sudo netstat -tnap | grep murmur
tcp        0      0 127.0.0.1:6502          0.0.0.0:*               LISTEN      765/murmurd

sudo ps aux | grep [m]urmur
105        765  0.0  0.2 191108  8268 ?        Sl   21:59   0:00 /usr/sbin/murmurd -ini /etc/mumble-server.ini

 

I install mumble-server with apt-get. Same as 1.2.2. With 1.2.2 Murmur starts automatically. Thought 1.2.3 starts automatically too. :?: Am i wrong?


Here is the whole Log wit the Restart at 00:14.

2011-02-24 00:07:11.559 Initializing settings from /etc/mumble-server.ini (basepath /etc)

2011-02-24 00:07:11.559 OpenSSL: OpenSSL 0.9.8o 01 Jun 2010

2011-02-24 00:07:11.575 SSL: Adding recommended CA UTN-USERFirst-Client Authentication and Email

2011-02-24 00:07:11.577 ServerDB: Openend SQLite database /var/lib/mumble-server/mumble-server.sqlite

2011-02-24 00:07:11.586 DBus registration succeeded

2011-02-24 00:07:11.603 MurmurIce: Endpoint "tcp -h 127.0.0.1 -p 6502" running

2011-02-24 00:07:11.651 Murmur 1.2.3 (1.2.3-1~ppa1~maverick1) running on X11: Ubuntu 10.10: Booting servers

2011-02-24 00:07:11.869 1 => Announcing server via bonjour

2011-02-24 00:07:11.943 1 => Registration needs nonempty 'registername', 'registerpassword' and 'registerurl', must have an empty 'password' and allowed pings.

2011-02-24 00:14:04.635 Caught SIGTERM, exiting

2011-02-24 00:14:04.635 Killing running servers

2011-02-24 00:14:04.742 1 => Stopped announcing server via bonjour

2011-02-24 00:14:04.816 1 => Stopped

2011-02-24 00:14:04.816 Shutting down

2011-02-24 00:14:04.817 MurmurIce: Shutdown complete

2011-02-24 00:14:04.952 Initializing settings from /etc/mumble-server.ini (basepath /etc)

2011-02-24 00:14:04.953 OpenSSL: OpenSSL 0.9.8o 01 Jun 2010

2011-02-24 00:14:04.969 SSL: Adding recommended CA UTN-USERFirst-Client Authentication and Email

2011-02-24 00:14:04.970 ServerDB: Openend SQLite database /var/lib/mumble-server/mumble-server.sqlite

2011-02-24 00:14:04.980 DBus registration succeeded

2011-02-24 00:14:04.982 MurmurIce: Endpoint "tcp -h 127.0.0.1 -p 6502" running

2011-02-24 00:14:05.050 Murmur 1.2.3 (1.2.3-1~ppa1~maverick1) running on X11: Ubuntu 10.10: Booting servers

2011-02-24 00:14:05.165 1 => Server listening on [::]:63526

2011-02-24 00:14:05.239 1 => Announcing server via bonjour

2011-02-24 00:14:05.322 1 => Registration needs nonempty 'registername', 'registerpassword' and 'registerurl', must have an empty 'password' and allowed pings.

2011-02-24 00:14:12.363 1 => <1:(-1)> New connection: 192.168.150.122:50997

2011-02-24 00:14:12.538 1 => <1:(-1)> Client version 1.2.3 (Win: 1.2.3)

2011-02-24 00:14:12.683 1 => Starting voice thread

2011-02-24 00:14:12.757 1 => CELT codec switch ffffffff80000010 0 (prefer ffffffff80000010)

2011-02-24 00:14:12.898 1 => <1:Chris(1)> Authenticated

Link to comment
Share on other sites

In your last post the restart you are showing logs for is the manual restart? Am I correct?

It appears that the system is starting up mumble-server but for some reason it is not requesting to listen on the port 63526 for connections until you manually restart mumble-server.


If that is true, after manual restart it does show that the server is listening:

2011-02-24 00:14:05.165 1 => Server listening on [::]:63526

 

Your problem is that the server is not listening on port 63526 on all interfaces when the server starts up at boot. I am not an expert on murmur so I hope that someone else could help me diagnose your problem. I have one other thing for you to try next time you reboot your system. When you need to manually restart mumble-server try:

/etc/init.d/mumble-server restart

See if your result is any different. The "service mumble-server restart" should be using /etc/init.d/mumble-server but just to be sure we should give it a try. I hope that someone else knows something more to add. My only guess is that your mumble-server is starting up before your network interface(card) is initialized completely. We might need to change what order your services start up. Does your networking start automatically at boot? You are not using anything like wireless are you? When I get home tonight I can take a closer look at the startup script on my linux server.


Any other ideas/comments welcome!

Link to comment
Share on other sites

  • 3 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...