Jump to content
Mumble forums

Murmur 1.2 Not Available in Apt


aarmenaa
 Share

Recommended Posts

I have several problems following the Installation article to install the server. Debian 5.0 will only install 1.1.8. Newer versions of Ubuntu fail to install anything, and older versions will only install 1.1.8.

 

sudo add-apt-repository ppa:slicer

This doesn't seem to work on Ubuntu 9.10 or 8.04 LTS, at least not out of the box. You need some Python package for this to work:

 

sudo apt-get install python-software-properties

After installing that Python package, adding the repository, and updating apt, this is what I get in Ubuntu 9.10:

 

Reading package lists...
Building dependency tree...
Reading state information...
Initializing package states...
Writing extended state information...
The following packages are BROKEN:
 mumble-server 
The following NEW packages will be installed:
 dbus{a} libavahi-client3{a} libavahi-common-data{a} libavahi-common3{a} 
 libavahi-compat-libdnssd1{a} libexpat1{a} libprotobuf3{a} libqt4-dbus{a} 
 libqt4-network{a} libqt4-sql{a} libqt4-sql-sqlite{a} libqt4-xml{a} 
 libqtcore4{a} 
0 packages upgraded, 14 newly installed, 0 to remove and 8 not upgraded.
Need to get 3985kB of archives. After unpacking 13.6MB will be used.
The following packages have unmet dependencies:
 mumble-server: Depends: libiceutil33 which is a virtual package.
                Depends: libzeroc-ice33 which is a virtual package.
The following actions will resolve these dependencies:

Keep the following packages at their current version:
mumble-server [Not Installed]

Score is -9881

Accept this solution? [Y/n/q/?]

Are there any updated instructions anywhere? I'd prefer instructions for Debain, but I know their stuff's usually older, so Ubuntu will do.

Link to comment
Share on other sites

The testing repo of Debian contains a mumble-server version 1.2.1 :)

The unstable repo of Debian contains a mumble-server version 1.2.2 :D

You could try to add one of these repos to your source list.


Your two missing dependencies could be due to the fact that these packages are not available in the stable repo of Debian. The testing and unstable repos do have these packages available. As Ubuntu is based on Debian, but uses a mix of its stable,testing,unstable repos for its bases, these missing packages in the Debian's stable repo could cause your problem. Look with synaptic or aptitude if these virtual packages are related at any or multiple real packages.

Computer specs: AMD FX-8320, 8GB DDR3-SDRAM, AMD Radeon HD 7950, Asus Xonar D1, Windows 7 Ultimate 64bit/Debian Jessie AMD64.

Link to comment
Share on other sites

I ended up just installing Debian Testing (squeeze). I read some stuff on the Ubuntu situation, and apparently 1.2 just isn't getting packaged until the next release which is still at least a couple months away. Every discussion mentioned that the PPA should still let you get up to date, so I guess I'm just missing something, becuase I wasn't able to make that work no matter what I tried. Thanks for the help!

Link to comment
Share on other sites

I tried the PPA for Ubuntu 8.04 and only got 1.1.8-3 digging in a little more and found https://launchpad.net/~slicer/+archive/ppa?field.series_filter= and it says you need Ubuntu 9.04 or newer.To apt-get it, but you can always compile it. In my case the laptop has a ATI X600 running anything higher then 8.10(?) and I lose video support ( thanks ATI )

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...