Jump to content
Mumble forums

User Timeout (Disconnect/Reconnect)


perfectform
 Share

Recommended Posts

Hello,

I recently moved my Mumble server from a Windows 7 64-bit box (little to no issues) to a different Ubuntu Server 10.10 64-bit box. Since the move, users have been timing out just about every 18 minutes. This causes them to disconnect from the server, and since they have their client set to "Automatically Reconnect" they reconnect right away. It causes some issues because the users are often speaking when they are disconnected/reconnected.


I believe the issue can be narrowed down to either a Linux issue or a wireless issue, as those are the main differences between the servers. I might add that I am able to connect to the Mumble server on the same network, without the timeouts. I do use ddclient on the Ubuntu Server because my ISP has a dynamic ip. However, the ddclient daemon is set to run every 5 minutes, and the timeout is every 18 minutes precisely.


Please let me know any information you might need to help me resolve this issue.


Thank you.

Link to comment
Share on other sites

  • Administrators

So the server, old win7 and new ubuntu, are on your local network?


How did you move?

Copy over the Murmur sqlite and install a new srv? Was it the same version of Murmur?


Do you have other servers? Do they have issues / disconnects all 18 mins?

Link to comment
Share on other sites

Thanks for the reply. I'll do my best to answer your questions.

 

So the server, old win7 and new ubuntu, are on your local network?

Yes, both are on my local network.

 

How did you move?

Copy over the Murmur sqlite and install a new srv? Was it the same version of Murmur?

I copied the Murmur sqlite file into a new mumble-server install. I setup mumble-server.ini to point to the location of this file. Initially, I used the ubuntu mumble-server build, which I believe was a different version from the win7 version, so I updated to the PPA: Slicer build, same issue.

 

Do you have other servers? Do they have issues / disconnects all 18 mins?

Not really, but I do run vnc on the ubuntu server, and have not had any disconnects, even when connecting from outside.

Link to comment
Share on other sites

Server Side Log:

2011-03-21 01:58:59.424 1 => <56:hamstar(-1)> Timeout

2011-03-21 01:58:59.468 1 => <56:hamstar(-1)> Connection closed: [-1]

2011-03-21 01:58:59.510 1 => Ending voice thread

2011-03-21 01:59:13.295 1 => <57:(-1)> New connection: xx.xxx.xx.xxx:5372

2011-03-21 01:59:13.503 1 => <57:(-1)> Client version 1.2.2 (Win: 1.2.2)

2011-03-21 01:59:13.546 1 => Starting voice thread

2011-03-21 01:59:13.589 1 => <57:hamstar(-1)> Authenticated

2011-03-21 01:59:13.961 1 => <57:hamstar(-1)> Moved hamstar:57(-1) to MMO[6:1]


Client Side, iirc:

hamstar disconnected

hamstar connected

hamstar moved to channel MMO


Hope that helps. Also, the port after the ip looks odd to me considering I have the default mumble port set on the server.

Link to comment
Share on other sites

Right, my mistake.


I'm wondering if it's possible that the firewall on my router is somehow shaping traffic, even though the ports are forwarded. I might try setting the server to DMZ in the router settings tonight, when I get off work.


Also, I think I saw a post somewhere that Linux and my particular router (2WIRE 2700HG-B) don't like to play nice. If that's the case, it's no problem to get a different router. I just don't want to spend the money if I don't have to.


EDIT: I put the server in the DMZ and now I'm getting the timeout/disconnect on my local Win7 machine.

The exact client error is as follows:

[12:18:57 AM] Server connection failed: The remote host closed the connection.

Link to comment
Share on other sites

There have been cases of a clock drift causing a time-out. If your hardware clock is drifting away from the real time and your OS checks your clock regularly with a time server you could end-up with jumps in the system time. This system time is used for checking the time-outs of the connection. But I thought that this problem was fix in the latest version of murmur. Could you please check.

Computer specs: AMD FX-8320, 8GB DDR3-SDRAM, AMD Radeon HD 7950, Asus Xonar D1, Windows 7 Ultimate 64bit/Debian Jessie AMD64.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...