Jump to content
Mumble forums

Plugin - Mumble Link - Settings not persisting


KFiguerado
 Share

Recommended Posts

Hello,

 

I am currently in the process of integrating Mumble Link (and subsequently positional audio) into my game and I am running into an issue

 

From user to user, Link refuses to stay enabled. The steps to reproduce are as follows: clear out cache -> log in as user that can always get Mumble Link to connect -> log out of game -> clear cache -> log in as user that can sporadically get Link to connect -> Link does not connect.  I've tried this on multiple computers and multiple different users and there's only one user that can get Link "linked" consistently. I'm using a Mumble.ini file and leveraging some functionality that will copy this ini file to the cache once the game starts. I've also looked into the registry settings that get changed on login (even going so far as to change them myself to see if I can get consistent behavior) and it still is inconsistent.

 

The game and Mumble Link implementations are both cpp and the only variations I have from the wiki post on how to implement Mumble Link is the specific information (like context and identity) that Mumble Link requires.

Link to comment
Share on other sites

  • Administrators

Hm okay then all I can say about this is that most likely there is some sort of issue with communicating with the Link plugin via shared memory that makes the plugin think the connection has broken. Since I don't know the code of your game, there is not much else that I can say at this point...

Link to comment
Share on other sites

Okay I'll look into that and see if I come up with anything. My guess at the moment is maybe my game isn't setting the identity properly in the shared memory so it caches that value.

Currently my Link implementation is pretty basic and I open up an instance of Mumble with the Link.dll inside the plugins folder (along with the associated ini file to enable it). 

 

If I find a solution I'll be sure to post it to help out anyone that has the same issue. 

Link to comment
Share on other sites

2 hours ago, KFiguerado said:

Okay I'll look into that and see if I come up with anything. My guess at the moment is maybe my game isn't setting the identity properly in the shared memory so it caches that value.

Currently my Link implementation is pretty basic and I open up an instance of Mumble with the Link.dll inside the plugins folder (along with the associated ini file to enable it). 

 

If I find a solution I'll be sure to post it to help out anyone that has the same issue. 

Just to add onto this I followed this link when developing my implementation of the Link plugin: https://wiki.mumble.info/wiki/Link

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...