Jump to content
Mumble forums

Mumble Overlay Not Showing


zingerburger
 Share

Recommended Posts

I've had this problem for a long time now. The overlay used to work for any game I played but then one day, it disappeared all of a sudden. I doubt it's a DX11 issue because the overlay doesn't show even for DX9 games (even though it used to). I've never changed anything and the "Enable Overlay" box is ticked. I've tried adding programs to the white-list but that doesn't help either. Can anyone help?

Link to comment
Share on other sites

Do you still remember what you did on that one day that the overlay disappeared?


What version of mumble do you run and which OS are you using? This will help narrowing the search.


Go to this wiki page, get DebugView and enable more verbose debugging in overlay. Hopefully this will give you some more info on what is going wrong. If you can not find anything yourself, post a part of the console log here.

Computer specs: AMD FX-8320, 8GB DDR3-SDRAM, AMD Radeon HD 7950, Asus Xonar D1, Windows 7 Ultimate 64bit/Debian Jessie AMD64.

Link to comment
Share on other sites

Sorry, I can't remember. Like I said, it's been doing this for a long time now but I never bothered trying to fix it. It's only now that it's starting to annoy me because I can't tell if someone has left or entered the channel or anything like that.


I'm also running version 1.2.3 and Windows 7 with all updates, and I've attached a screenshot of DebugView that shows what happens when I start Mumble, if it helps.

debugnooverlay.jpg.b5943206a7025a856912c67c8ce6cbc5.jpg

Link to comment
Share on other sites

Now put a file called "debugoverlay" into the client installation directory. Start mumble and DebugView and start a game that needs to be overlayed. Provide us with the output of DebugView of when the game starts. I think there is an option to copy paste the DebugView output, so you do not need to make a figure from it.


BTW, was you audio input device disconnected. WASAPIInput says. Failed to open input device: hr=0x80070490

Computer specs: AMD FX-8320, 8GB DDR3-SDRAM, AMD Radeon HD 7950, Asus Xonar D1, Windows 7 Ultimate 64bit/Debian Jessie AMD64.

Link to comment
Share on other sites

[2892] HardHook: Asked to replace 751CED12 with 01314E60

[2892] HardHook: Unknown opcode at 0: b8 14 10 0 0 b9 0 0 0 0 8d 54

[2892] HardHook: Asked to replace 751CF170 with 01314E10

[2892] HardHook: Unknown opcode at 5: 8b ff 55 8b ec 6a 5d ff 75 8 e8 e6

[2892] DirectSound: Disabled as WASAPI is available

[2892] ASIO: No valid devices found, disabling

[2892] LGLCD: Unable to initialize Logitech LCD library 1722

[2892] CELT bitstream 8000000b from C:/Program Files (x86)/Mumble/celt0.0.7.0.sse2.dll

[2892] CELT bitstream 80000010 from C:/Program Files (x86)/Mumble/celt0.0.11.0.sse2.dll

[2892] Locale is en_AU

[2892] Database SQLite: "3.6.19"

[2892] Overlay: Listening on "\\.\pipe\MumbleOverlayPipe"

[2892] AudioInput: 44410 bits/s, 48000 hz, 480 sample CELT

[2892] WASAPIOutput: Latencies 100000 30000 => 100000

[2892] WASAPIInput: Latencies 100000 30000 => 100000

[2892] WASAPIInput: Stream Latency 58050 (882)

[2892] Adding device {6f1d2b60-d5a0-11cf-bfc7-444553540000} Mouse Mouse:8

[2892] Adding device {6f1d2b61-d5a0-11cf-bfc7-444553540000} Keyboard Keyboard:127

[2892] WASAPIOutput: Stream Latency 116100 (882)

[2892] WASAPIOutput: Periods 10000us 3000us (latency 11610us)

[2892] WASAPIOutput: Buffer is 20000us (1)

[2892] AudioOutput: Initialized 2 channel 44100 hz mixer

[2892] AudioInput: Initialized mixer for 1 channel 44100 hz mic and 2 channel 44100 hz echo

[2892] Adding device {eaf2e150-10c2-11df-8001-444553540000} Logitech USB Headset Logitech USB Headset:8

[2892] AudioInput: ECHO CANCELLER ACTIVE

[2892] OpenSSL Support: 1 (OpenSSL 1.0.0c 2 Dec 2010)

[2892] SSL: Adding recommended CA AAA Certificate Services

[2892] SSL: Adding recommended CA UTN-USERFirst-Client Authentication and Email

[2892] ServerHandler: QOS2 loaded

[2892] LogDocument::loadResource 2 "http://effortless-precision.com/images/epmumble.png"

[2892] LogDocument::loadResource 2 "http://www.xboxist.com/xbox-360/2011/01/05/Homefront_icon.jpg"

[1456] ExecCommandLine: ""C:\Program Files (x86)\Steam\steam.exe" steam://rungameid/55100 "

[1456] ExecSteamURL: "steam://rungameid/55100"

[1456] Game update: AppID 55100 "HOMEFRONT", ProcID 2764, IP 0.0.0.0:0

[2764] DefaultOnlineSubsystemName: GCOnlineSubsystemSteamworks.GCOnlineSubsystemSteamworks

[1456] Warning: DirectSound playback reset due to non-moving playback cursor (buggy sound driver) time: 220 play: 0 write: 0.

[1456] ... all components successfully initialized.

[1456] Game removed: AppID 55100 "HOMEFRONT", ProcID 2764

[1456] Error: texture file 'public\steam_cloudsync' does not exist or is invalid

[3064] [14:18:48:159]

[3064] Could not get base file name for CP_Guest_3064(1)_ver3:;crysis2_dd - missing url attribute

[3064]

[3064] [14:18:59:381]

[3064] DownloadMgrImpl shutdown - already shutdown

[3064] [14:18:59:381] CoreTokenManager::RemoveHandler - Attempting to remove a handler for an unhandled type:"eadtoken:"



I should also add that I tried loading up Bad Company 2 but nothing showed up on this debug list. Homefront and Crysis 2 overlays work for my friends so I started up those games.

Link to comment
Share on other sites

Something most have gone wrong, because I do not see any overlay debug info. Did you put the empty file debugoverlay in the installation directory of the game that needs to be overlayed. There should be a line in DebugView saying "Overlay debug found". If this line is missing try another game for which you know where the executable is installed.

Computer specs: AMD FX-8320, 8GB DDR3-SDRAM, AMD Radeon HD 7950, Asus Xonar D1, Windows 7 Ultimate 64bit/Debian Jessie AMD64.

Link to comment
Share on other sites

Yep, I did. I've tried all of my installed games and I can't get that "Overlay debug found" line to come up in DebugView. Here's exactly what I'm doing, in case I'm doing something wrong:


1. Go to the folder where the .exe file of the game is installed e.g. C:\Program Files (x86)\Electronic Arts\Crytek\Crysis 2\bin32

2. Copy-pasting one of the files that has a .dll extension into the same folder

3. Rename that .dll file by deleting the .dll extension and calling it "debugoverlay" (without the quotation marks)

4. Starting DebugView

5. Starting Mumble

6. Starting the game from the .exe file in the game's installation folder (i.e. I'm not using the desktop shortcut to start the game)


I don't get anything in DebugView that says the debugoverlay file was found, no matter which game's installation directory I put the debugoverlay file into.

Link to comment
Share on other sites

Could be that binary content of your "debugoverlay" file is causing this behavior. Try making a empty text file and rename it to debugoverlay.


You could also try the latest snapshot version of mumble, to see if that solves your overlay problem. There have been some changes to the overlay since the release of 1.2.3. These changes solved some problem that people were having.

Computer specs: AMD FX-8320, 8GB DDR3-SDRAM, AMD Radeon HD 7950, Asus Xonar D1, Windows 7 Ultimate 64bit/Debian Jessie AMD64.

Link to comment
Share on other sites

Nope, nothing. Empty text file didn't work and the snapshot update didn't work either. I'm just going to leave it for now. It's just annoying when I can't tell whether someone has left or entered the channel (especially if I'm playing a game and the explosions drown out what Mumble tells me) but it's not a huge problem. Thanks for the help though.

Link to comment
Share on other sites

Last try. I have taken another look at your debugview output. I looks like the overlay library is not functioning at all. There should be messages from the overlay code in debugview for dx9/dx10 related programas, even when overlaydebug is not in the installation directory. So do the following, to make a fresh installation of mumble.


- export your certificate, so you can import it later.

- uninstall mumble.

- go through the registry with regedit and remove all keys related to mumble. You can use the search option in regedit.

- install a fresh mumble and start it.

- import you certificate.


P.S.: If you run mumble portable (-m flag), then that could be your problem. But I am not 100% sure.

Computer specs: AMD FX-8320, 8GB DDR3-SDRAM, AMD Radeon HD 7950, Asus Xonar D1, Windows 7 Ultimate 64bit/Debian Jessie AMD64.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...