Jump to content
Mumble forums

Mumble lagging my game


xean0r
 Share

Recommended Posts

Without mumble on, I am fine, when I turn it on, I lag badly and it ruins my game (League of Legends). My FPS is fine, but it appears my CPU usage on mumble is sitting at 13-20% while idle and this is with audio processing and overlay turned off. This is VERY strange to me considering I have a 2.4GHz dual core machine. Any suggestions besides turning the priority down?

Link to comment
Share on other sites

The lag could also be related to your internet connection. You could try to force mumble to use TCP mode and/or disable QoS.


BTW: What do you mean by audio processing turned off? There will always be some audio processing being done, like noise reduction, AGC and encoding.

Computer specs: AMD FX-8320, 8GB DDR3-SDRAM, AMD Radeon HD 7950, Asus Xonar D1, Windows 7 Ultimate 64bit/Debian Jessie AMD64.

Link to comment
Share on other sites

Meaning I turned both processing sliders to the far left. I considered internet usage, but Ventrilo does not lag me at all and I have the compression turned down a bit trying to solve this issue. The lag I'm experiencing is a stutter that even results in my commands not going through at some times and it appears my CPU is at 100% with both running.


I changed my network settings like you suggested and I'll find out later if that solved my problem.

Link to comment
Share on other sites

Have you encountered any CPU load change by playing with the Audio Processing sliders? I think moving the sliders to the far left will not help reduce the CPU load. Mumble will still do audio processing, but just with different settings.


I just noticed that you said your FPS do not change, this also indicates that it is not a CPU load problem.

Computer specs: AMD FX-8320, 8GB DDR3-SDRAM, AMD Radeon HD 7950, Asus Xonar D1, Windows 7 Ultimate 64bit/Debian Jessie AMD64.

Link to comment
Share on other sites

Update:


My FPS is actually dropping from 60 to 20ish on closer inspection. It is processor load and I can't fathom how my machine can't handle this... setting priority to game to high and mumble to low didn't help much. Turning down all the graphics to low in the game also helped.

Link to comment
Share on other sites

Got a few friends complaining about the same thing, mostly dualcore guys. I have it ok on my quad, but still 10% cpu usage on a 3ghz quad cpu for mumble? Thats a bit drastic, considering ventrilo used to take 2-5% on singlecore 1.5 ghz cpu. Thats a more than tenfold increase over ventrilo...

Link to comment
Share on other sites

To be clear we are not a commercial company, but just some coders how give their free time in improving mumble. So posing that we need to do something is a bit strong to my taste. Something in the line of "It would be nice if someone would take the time to lower the CPU usage of mumble." is nicer, but maybe a bit overdone.


I have check the CPU usage on my Linux box(see sig for detail). The CPU usage is around 4%, but when I turn on echo cancellation the usage goes up to 10%. And when I use multichannel (5.1) echo cancellation it even goes up to 26%.


So just try to disable echo cancellation and see what happens.

Computer specs: AMD FX-8320, 8GB DDR3-SDRAM, AMD Radeon HD 7950, Asus Xonar D1, Windows 7 Ultimate 64bit/Debian Jessie AMD64.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...