Jump to content
Mumble forums

Noise filtering options on Mac client


tsuxiit
 Share

Recommended Posts

It would be nice if the Mac client included options to decrease or disable the amount of noise filtering that goes on during signal transmission. I often have difficulties being understood because of the way my microphone sounds (a great deal of my words are filtered out as noise). It would also make it possible to play music or other sounds over the server without alot of quality degradations. I really hope some better options are available on the next version of the Mac client!

Link to comment
Share on other sites

In the Audio Input settings there is a section called Audio Processing. Here you can change the noise suppression and amplification. The default setting is NS:-30dB, Amp:20.00, but the Audio Wizard will change these settings. Try to play with these setting to see if it helps.


BTW, have you ran the Audio Wizard.

Computer specs: AMD FX-8320, 8GB DDR3-SDRAM, AMD Radeon HD 7950, Asus Xonar D1, Windows 7 Ultimate 64bit/Debian Jessie AMD64.

Link to comment
Share on other sites

There are no such settings on the Mac client. I know they exist on the Windows client. Here's a screenshot of the only settings available for Audio Input on the Mac client:


edit: OH snap! I never noticed that little tiny "Advanced" button. I clicked it, lo and behold success! Thanks for making me realize my error, rawnar!


edit: Okay, second edit. I turned the noise suppression to "off" for both the sending and receiving client, but after 3 seconds of playing music or so, the client continues to suppress the lower frequencies that it calls noise, i.e. there is no change in behavior despite changing the value in the settings.

Link to comment
Share on other sites

Noise suppression is just one part of the chain, that is called sound processing.


Another thing that effects the sound quality is the compression method. AFAIK the present stable client still has support for the Speex codec, but that has been dropped in the snapshots. The Speex codec was designed for speech, so it has an narrower bandwidth then a codec like MP3, and will not work well with music. The other compression method is CELT, designed to also work well with music. In the Audio Input configuration there are two bars in the box called compression. Try to play with these two bars and keep the codec at CELT.


Good luck fiddling with the setting. And keep in mind the program was made for VoIP and not MoIP(Music over IP) ;)

Computer specs: AMD FX-8320, 8GB DDR3-SDRAM, AMD Radeon HD 7950, Asus Xonar D1, Windows 7 Ultimate 64bit/Debian Jessie AMD64.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...