Jump to content
Mumble forums

Multiple Users on one computer


morpheusninja
 Share

Recommended Posts

Add "-m" after the mumble executable in the command line. Now you can start multiple instances of mumble.


Also you need to copy the installation directory to another map. The -m options will use the directory where mumble is started from as the directory to save the settings. So for every instance of mumble you need a new directory. Be aware that some function will stop to work when starting mumble with -m flag.

Computer specs: AMD FX-8320, 8GB DDR3-SDRAM, AMD Radeon HD 7950, Asus Xonar D1, Windows 7 Ultimate 64bit/Debian Jessie AMD64.

Link to comment
Share on other sites

... Be aware that some function will stop to work when starting mumble with -m flag.

Yeah like the function to login as another user? ;)


I'm actually after this at the moment as well as I would like to connect one account just like normal with a headset, but my second account will be a radioplayer where Winamp will be the host of the music.


Together with "Virtual Audio Cable" I know I'm able to make Winamp a microphone and output the music on mumble, that surely works without any problems.

However, I'm having problems with being logged in to two different accounts at once. I've used the -m solution, I've tried running as a different user and all I can think of I guess.. I hope not though!


I've managed to run two instances of Mumble on my Win7 64-bit machine, so far it works. I then login with one of the instances to the server, no problems there, using toffo as username.. But when I try and connect on the second instance with username winamp instead, I get logged in as toffo on the second instance as well, resulting in me being kicked from the first instance.


I have both instances in separate folders, I've tried both with and without murmur.ini in the folders and I've tried running as a different user and as an administrator and it does the same thing every time.


Are there any solutions to this? Sure I have more computers that I could use to get it to work, but I would surely love to see it working on one computer.

Link to comment
Share on other sites

Yeah like the function to login as another user?

 

I was more talking about the black and white list for the overlay. As it uses the registry to transport the settings to the overlay it will not work with the "-m" flag. The "-m" flag will suppress saving the settings to the registry.


Back to your problem. Murmur.ini has nothing to do with the problem,as it only used by the server and not the client. My first guess will be that you do not have write permission for the folder you are running the second instance of mumble from. You could also try running them with different users and not add the "-m" flag.


Are you running both instances of mumble with the "-m" flag?

Have you checked the shortcuts that they are using the correct working directory?

Computer specs: AMD FX-8320, 8GB DDR3-SDRAM, AMD Radeon HD 7950, Asus Xonar D1, Windows 7 Ultimate 64bit/Debian Jessie AMD64.

Link to comment
Share on other sites

  • Administrators
However, I'm having problems with being logged in to two different accounts at once. I've used the -m solution, I've tried running as a different user and all I can think of I guess.. I hope not though!

 

I've managed to run two instances of Mumble on my Win7 64-bit machine, so far it works. I then login with one of the instances to the server, no problems there, using toffo as username.. But when I try and connect on the second instance with username winamp instead, I get logged in as toffo on the second instance as well, resulting in me being kicked from the first instance.


I have both instances in separate folders, I've tried both with and without murmur.ini in the folders and I've tried running as a different user and as an administrator and it does the same thing every time.



That is because you connect with the same (user-)certificate which is recognized by the server as registered to an account and you are thus logged in to that account.

Use the -n (I believe) Option to start without an active certificate, or use an .ini file for the clients settings to set up different certificates for the 2 installations (as you seem to have tried).


Murmur.ini is for the server.

Create a Mumble.ini instead.


In mumble you can select your input device. So as long as you mic indeed a second device that should work.

Link to comment
Share on other sites

Firstly, I see that I wrote wrong in my previous post, I've indeed used mumble.ini and not murmur.ini, I guess I like the name murmur more than mumble or something ;)


rawnar

Ah okey, well I wasn't "serious" with my question there ;) I just thought it was a funny addon to my post as I'm having problems as well ;)



kissaki

Thanks for your reply! That sounds like a really good explanation to my problem ;)



Final result.....

Well that did it!! I'm actually using both -m and -n but it sure works, it works so good that I just love Mumble as much as anyone can! :D

Thanks for your replies guys! I really appreciate it, now me and my girlfriend can listen to music together while chatting when she's at her parents house!

Totally awesome, thanks again! :D

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...