Jump to content
Mumble forums

Disable "Auto Volume Change"


dke-
 Share

Recommended Posts

Hi,


I've noticed that there's something in mumble that is checking the current DB output on the soundcard and lowers the volume in mumble to make it sound "better" in my opinion this is working really bad and it's just annoying when people keep fading in and out cause their voice is not at a constant volume.


It's a nice idea but executed poorly. Is there a way to completely disable this?


A way to trigger it is to play a song that fills the sound spectrum (electronic music preferable) and have it at high max volume. Stop winamp and then instantly talk on mumble, you'll notice that everyone will say "You're super low volume, turn it up", wait 5 seconds, and you're back to normal volume. Is there a way to just completely disable this feature?

Link to comment
Share on other sites

it's not measuing sound output, it's measuring sound input. the only way winamp could be triggering this is if you've your sound input set to "what-u-hear" or "wave out mix" or whatever your soundcard calls it. Apart from anything else, if you do, then any time someone speaks while you're transmitting, you'll echo their voice back to them. Switch your input device to your mic.

Link to comment
Share on other sites

Hmm, i'm unsure, maybe winamp is set to wave out, but it only says "output creative x-fi" on winamp. Either way, the winamp isn't the problem i just tried to point out that mumble is indeed doing something with the volume all the time. I've tried to disable it in audio output without success. Is there a way to comment out the code in the source and simply compile a client without this feature?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...