Jump to content
Mumble forums

Invalid channel name after altering murmur.ini


althal
 Share

Recommended Posts

Hello everyone.


Here is what has happened:

I am using Multiplay.co.uk as my Mumble server (1.2.3) provider - maybe someone is familiar with their config.

In their Control Panel I have a limited access to my murmur.ini file.

By "limited" I mean I can see and edit only the following:

# How many login attempts do we tolerate from one IP
# inside a given timeframe before we ban the connection?
# Note that this is global (shared between all virtual servers), and that
# it counts both successfull and unsuccessfull connection attempts.
# Set either Attempts or Timeframe to 0 to disable.
autobanAttempts=10
autobanTimeframe=120
autobanTime=300

welcometext="Welcome!"

# To enable public server registration, the serverpassword must be blank, and
# this must all be filled out.
# The password here is used to create a registry for the server name; subsequent
# updates will need the same password. Don't lose your password.
# The URL is your own website, and only set the registerHostname for static IP
# addresses.
#
registerName="$$name$$"
#registerPassword="secret"
registerUrl="http://www.multiplaygameservers.com/"
#registerHostname=$$ip$$

# Core settings - DON'T CHANGE
port=$$port$$
users=$$max_players$$
serverpassword=$$game_passwd$$
host=$$ip$$
bandwidth=560000

 

I wanted to add the ability to create new channels with special characters like &, [, ] etc., so following this murmurguide section I have added the following line at the end of murmur.ini:

channelname=[ \\-=\\w\\#\\[\\]\\{\\}\\(\\)\\@\\|\\%\\&]+

After server restart I can't create a channel whether or not it contains the special characters.

Attempt to create either MightAndMagic or Might & Magic channels results in "Denied: Invalid channel name" message.

I have tried to correct the problem by removing the additional line from murmur.ini and restarting, but after that I am still getting the same error - "Denied: Invalid channel name".

Unfortunately Multiplay Support after an hour of tests couldn't rectify the problem and asked me to talk to the developers to get a better understanding what might have gone wrong.

So what I am here after is:

- What is the possible cause?

- Could this change to murmur.ini affect database/files maybe and this needs correcting now?


The Multiplay Support team want to recreate my Mumble server from scratch, but this means loosing my user database, registrations etc. and I don't really want to lose the setup for over 300 registered users, channels, groups...

In case we can't solve the problem - is it possible to export users, channels setup, groups from the old server and import it to the new one? How to do it?


Kind regards,

Mike

Link to comment
Share on other sites

Thank you for your advice commandchannel, but unfortunately this is not what I have been asking for.

I want to go back to default settings and I am trying to understand why removing the "channelname" line from settings didn't correct the issue.

Is it possible that the server doesn't use the standard murmur.ini config file?

Also - is it possible to export users, channels setup, groups from the old server and import it to the new one? How to do it?

Link to comment
Share on other sites

To go back to the default settings you only need to remove the channelname line (or comment it out). Your host is clearly doing something with the ini file, as the standard murmur.ini does not support tokenization.


The only way I know of to export your configuration is to take the whole sqllite database.

Mike Johnson

Command Channel

Providing Mumble Servers since 2009.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...