Jump to content
Mumble forums

UDP packets cannot be sent to the server


korvboll
 Share

Recommended Posts

Just installed a Mumbleserver and almost everything works great.

Got 2 problems that I can't find any explanation for however.


1) For some reason it takes 29 seconds to connect to the server. Always 29 seconds, I've timed it :). I have no idea how to explain this as no other program takes this long to connect (such as ventrilo). This should indicate that the servercomputer/router is incorrectly set up. This happens to almost everyone that connects, while some people always connect instantly. :?


2) 9/10 times when someone connects they get an error saying "UDP packets cannot be sent to the server, switching to TCP mode". When this happens you can hear what other people say, but you can't speak since you lag extremely much. I have never experienced this before and I don't know what to do. Both UDP and TCP ports are open, and what makes it hard to identify is that the problem only appears sometimes, and sometimes it just fixes itself after a couple of minutes. When it fixes itself the log says something like "receiving UDP packets, switching back to UDP mode" and everything stops lagging.


Should add that the server isn't on my computer, it's on a servercomputer a couple of miles away.


I really prefer this program over Ventrilo and Teamspeak so any support would be appreciated.

Link to comment
Share on other sites

  • Administrators

The connection time of 29 seconds could be due to the UDP-timeout, as UDP can't be sent.

Do those ppl. who get the message about UDP packages not going through and switching to TCP-mode have the 29 second connection?

Or is that entirely independent?


Anyway, something on your host, host network setup or host router is really fucked up.

Do you use anything to prevent flooding/dos-attacks or the like? Maybe UDP is blocked there.

Otherwise… well, UDP is not coming through, so something is misconfigured.

Link to comment
Share on other sites

Don't really understand the second sentence you wrote there. Almost everyone has the long connection time, apart from very few people who connect instantly for some reason.


This servercomputer that Murmur lies on runs several other programs that has never had any similar problems. The router has been installed for like 2 years and It's set up fine for everything else. But mabye there's something specific you need to change for Murmur to work? Doesn't seem likely.

Link to comment
Share on other sites

Are those other things also relying on UDP?

 

Good question. I have no idea, but seeing as it's like 5 different programs, chances that one of them is using UDP is quite high.

Let's say that none of them are, and only Murmur is the one using UDP, what setting in the router could it be that is incorrectly set up? Like I wrote, both TCP and UDP port 64738 is open. Haven't checked windows firewall and antivirus though, but if they block they should block all or nothing. Can't assume that though, I will check that tomorrow.

 

What I was asking is:

Are those ppl. that can't connect instantly also those ppl. who get the UDP-error?

 

Just tried this with some friends. Two people connected instantly with no error while me and another guy took 29 seconds to connect, and we didn't get any error either. It seems so random :(

Edit: Just to clarify: I always connect slowly, and I lag sometimes. The people who connect instantly seem to always connect instantly, though I'm not sure if they can get the lag or not. Would need more testing I guess.

Link to comment
Share on other sites

  • 4 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...