Jump to content
Mumble forums

Mumble server crashes


checooh
 Share

Recommended Posts

Hello!


I've got a problem with my Mumble server on CentOS 5 VDS. It worked ok about 3 months, but today it started to crash after about 5 min. working. Some users log in (it doesn't depend on users number), and after a while it stops working. murmurd.log says following:

 

<W>2012-05-05 16:36:16.377 Initializing settings from /etc/murmurd (basepath /etc)
<W>2012-05-05 16:36:16.377 Binding to address <server IP>
<W>2012-05-05 16:36:16.393 SSL: Added CA certificates from '/etc/pki/tls/certs/ca-bundle.crt'
<W>2012-05-05 16:36:16.402 ServerDB: Openend SQLite database /var/lib/murmurd/murmurd.sqlite
<W>2012-05-05 16:36:16.405 Failed to connect to D-Bus session
<W>2012-05-05 16:36:16.406 OSInfo: Failed to execute lsb_release
<W>2012-05-05 16:36:16.406 Murmur 1.2.2 (Compiled Feb  9 2010 17:44:13) running on X11: Linux 2.6.18-308.el5.028stab099.3: Booting servers
<W>2012-05-05 16:36:16.417 1 => Server listening on <server IP>:64738
<W>2012-05-05 16:36:16.429 1 => Not registering server as public
<W>2012-05-05 16:36:21.042 1 => <1:(-1)> New connection: <user1 IP>:53668
<W>2012-05-05 16:36:21.199 1 => <1:(-1)> Client version 1.2.3 (Win: 1.2.3)
<W>2012-05-05 16:36:21.211 1 => Starting voice thread
<W>2012-05-05 16:36:21.220 1 => CELT codec switch ffffffff80000010 0 (prefer ffffffff80000010)
<W>2012-05-05 16:36:21.228 1 => <1:user1(-1)> Authenticated
<W>2012-05-05 16:36:22.649 1 => <2:(-1)> New connection: <user2 IP>:59293
<W>2012-05-05 16:36:22.823 1 => <2:(-1)> Client version 1.2.3 (Win: 1.2.3)
<W>2012-05-05 16:36:22.884 1 => <2:user2(1)> Authenticated
<W>2012-05-05 16:36:24.523 1 => <3:(-1)> New connection: <user3 IP>:58093
<W>2012-05-05 16:36:24.724 1 => <3:(-1)> Client version 1.2.3 (Win: 1.2.3)
<W>2012-05-05 16:36:24.729 1 => <3:user3(-1)> Authenticated

 

When I try to run it from console with -fg parameter it says the same, plus when it crashes, it says "Killed". Server is VDS, and dmesg doesn't show anything at all, other log files don't contain anything relevant.

Link to comment
Share on other sites

I tried reinstalling and upgrading to 1.2.3 too, with the same result. VDS technical support said that "OS killed the service, because it requested too much resources." and that "This software won't work on VDS." They even didn't want to listen that it worked ok for a long time. For me, the solution was to replace murmurd with Teamspeak server. Maybe there are settings to limit resource demand for murmurd?

Link to comment
Share on other sites

I tried reinstalling and upgrading to 1.2.3 too, with the same result. VDS technical support said that "OS killed the service, because it requested too much resources." and that "This software won't work on VDS." They even didn't want to listen that it worked ok for a long time. For me, the solution was to replace murmurd with Teamspeak server. Maybe there are settings to limit resource demand for murmurd?

Will you run into the same issue with Teamspeak two years (or less) from now?


Perhaps it's time to look for a different service provider, or to look at getting a low-end dedicated server instead of a virtual server. An Atom server should be more than powerful enough to handle a single Mumble server, and you should be able to find one for around $40/month.

Mike Johnson

Command Channel

Providing Mumble Servers since 2009.

Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...