Jump to content
Mumble forums

Popping


jitspoe
 Share

Recommended Posts

I'm experiencing a lot of popping in Mumble. I've recorded some samples where it happens.


http://jitspoe.com/forforums/mumble/mumble_pop1.wav

http://jitspoe.com/forforums/mumble/mumble_pop2.wav

http://jitspoe.com/forforums/mumble/mumble_pop3.wav

http://jitspoe.com/forforums/mumble/mumble_pop4.wav

http://jitspoe.com/forforums/mumble/mumble_pop5.wav


These are just from when the voice activation was picking up some background noise - no talking - that tends to be when it happens the most, or maybe that's just when I notice it the most because things are quiet.


It seems there are 2 kinds of pops. The first one I expected:

http://jitspoe.com/forforums/mumble/mumble_pop1.png


It looks like there is no fade in when the sound starts. If the wave is near the center, it's not a problem, but if it happens near the peak of a large wave (like this), there's an audible pop.


If it just had a quick blend when the sound started, it would fix that issue. Something like this:

http://jitspoe.com/forforums/mumble/mumble_pop1_shouldfade.png


The second one is kind of odd:

http://jitspoe.com/forforums/mumble/mumble_pop2.png


It looks like maybe the sign was swapped for one segment of the wave? Like it was negative when it should have been positive? Maybe an overflow of a signed integer? This usually happens near the beginning of a transmission. I don't normally hear popping mid-sentence.


In both of these cases, it looks like the pop happens before the compression and/or filtering.


Some things to note:

- This happens with multiple different people.

- This happens on both my integrated (Realtek) and X-Fi sound cards.

- This does not happen on other VOIP programs with the same people (Skype, Ventrilo, etc.)

- I've tried adjusting the Output Delay and Default Jitter Buffer. Even when these are maxed out, the issue still occurs.


----


Ok, I decided to do a lot more testing with the local loopback before testing this, so here's some more info:


I was able to get a pop pretty frequently with the local loopback (no delay or packet loss) just by saying "testing". This is an example of a couple bad cases:

http://jitspoe.com/forforums/mumble/mumble_local_loopback_testing.wav


Here's a raw recording directly from the microphone of me saying "testing" at a time when there was a bad pop (so it's not an issue with the microphone):

http://jitspoe.com/forforums/mumble/testing_raw.wav


I was also getting a lot of more subtle pops, such as this one:

http://jitspoe.com/forforums/mumble/subtle_pop.wav


It doesn't have an obvious jump in the wave form -- just looks like some waves are shifted over -- but it's very audible.


I tried carefully running through the audio wizard again, but I still get the pops. I thought maybe something in the audio processing was causing the issue, so I set the "Noise Suppression" to "Off". Different amplification values don't seem to change anything, either. Increasing the quality on the compression (even at the max) did not remove the popping.


I'm using the Logitech USB Microphone: http://www.logitech.com/webcam-communications/microphones/devices/221

Link to comment
Share on other sites

I downloaded the latest developer snapshot (in case something had been fixed that wasn't in 1.2.3 stable) on my laptop and tested it with the built-in mic. It has the same popping issues. I even noticed it when I was configuring the microphone in the wizard that pops up after you first install it. I'm about to take a look at the source code and see if I can find some potential problems. Not sure if the problem would be in mumble itself or speex.

Link to comment
Share on other sites

pcgod made a change that put limits when converting the floating point value to a short. That has stopped the pop where the wave jumps between positive and negitive. I'm still getting a pop, though. I can hear it plain as day, but it's very difficult to identify when looking at the wave. Best I could do was try to make a solid tone, and you can see the spike in the wave and notice things look like they're shifted a bit:


http://jitspoe.com/forforums/mumble/mumble_20120521_pop1.png

audio sample: http://jitspoe.com/forforums/mumble/mumble_20120521_pop1.wav


This was using http://mumble.info/snapshot/mumble-1.2.3-347-g814ae5e.msi with amplification set to 1, noise suppression off, quality at 96kb/s, and 20ms for audio per packet with local loopback.

Link to comment
Share on other sites

Looks like for some reason, part of the sample was lost, and the codec had to encode an instantaneous jump. While an artifact like that might be audible in a rather clean waveform, I doubt it'd make much of a difference in the usual noisy voice samples.

Link to comment
Share on other sites

Nothing should be lost as I'm doing this with a local loopback and no packet loss or delay. I posted that sample because it's about the only one that's visible when looking at the wave. Normal speech doesn't really provide visible pops in the wave form (though I imagine they'd be visible with spectrum analysis). Here's one of me just going "Woo":


http://jitspoe.com/forforums/mumble/mumble_20120521_pop2.png

Audio: http://jitspoe.com/forforums/mumble/mumble_20120521_pop2.wav


And here's me saying "Test.":

http://jitspoe.com/forforums/mumble/mumble_20120521_pop3.png

Audio: http://jitspoe.com/forforums/mumble/mumble_20120521_pop3.wav


With the "test" sample, you really can't see the pop at all just from looking at the wave, but you can hear it. You have to have a fairly consistent wave to even see what's going on.

Link to comment
Share on other sites

  • 6 months later...

Well, it seems most of these issues are fixed, but there is still no fade in when a sample starts. Here's a screenshot where that's pretty clear:


http://jitspoe.com/images/misc/mumble_nofade.png


Just a simple 10ms blend from 0 to full volume in would probably work wonders.


Another thing I've noticed is that it tends to over-amplify sound when it first starts. I started out making a quite tone, then getting progressively louder until the voice activation picked up and it transmitted:


http://jitspoe.com/images/misc/mumble_loudstart.png


As you can see, there's a burst where it's really loud, then it goes back to normal. The result here is that quiet sounds that should barely even pick up all of a sudden have a huge wave form, and without a blend, that huge wave can result in a pretty significant pop. I'm not sure if there's a reason for the amplification on start, but the way that wave SHOULD start out quiet and get progressively louder. It almost looks like it's blending a wave on top of itself briefly.

Link to comment
Share on other sites

  • 3 months later...

Hello, i have the same issue.


client version: 1.2.4 (1.2.4-rc1-8-gb115a29)

server version: 1.2.3-412-gbc9694d-ermine

codec: Opus

max. amplification = 40


This does not happen if max. amplification 1.5 or i dont hear it yet.


sorry for bad english )

Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...