Jump to content
Mumble forums

problem with .ini file


deadhound
 Share

Recommended Posts

I got a problem with murmur on linux opensuse 12.1


I got the server up and running, and add a superuser. The problem is that the server doesn't register or care about any changes done to the mumble-server.ini file. I tried to add welcome message, password and user limit and none works. I'm not using ice or Dbus.

Link to comment
Share on other sites

  • 1 month later...

I have this exact same problem with mumble-server on Ubuntu 12.04. I had the server working with zero problems until I had to re-install my OS. I had kept a backup of the mumble-server.ini file. It does seem that Ubuntu keeps a newer version of the package in the repos.


The .ini file resides in /etc/mumble-server.ini. Not only have I had to fix various permissions issues, but even after resolving those the murmurd command finally goes off without a hitch. I can connect to the server with now troubles. However it pays no attention to any of the configurations I have made to the .ini file with the exception of the host I have provided. For instance, any changes to the server password, welcome message, register name, and number of allowed users only use the default settings when connecting. I have restarted the server, directed to the correct mumble-server.ini, and reinstalled the package, and even downgraded to an older version with no luck.


If anyone has found a solution to this it would be greatly appreciated.

Link to comment
Share on other sites

  • Administrators

You could try (re)moving your server sqlite. Maybe those settings have been explicitly set on your virtual server, thus the ini settings - which are used as defaults/fallbacks for the vservers - are not used.

If you don't have any server data (in sqlite) you need to keep, this may be a solution if it fixes your problem.

Alternatively create a new vserver (if you have a webinterface).


You restart mumble-server after changing your ini, right?


Did you replace the ini? Or did you remove the old then copy in your backed up one?

You do start the server via /etc/init.d/mumble-server which is provided with the package?

Link to comment
Share on other sites

Ok, I have deleted every possible instance of a murmur.sqlite file I could find. (I think there were more because at one point I had tried putting them in different default directories). When murmur starts up and there is no database file present it creates the file itself. However this new file does not solve the problem. Yes I restart the murmur process through /etc/init.d/mumble-server every time I edit the mumble-server.ini file so it should adhere to any changes. It still lets me connect to the server with the hostname I provide but the rest of the settings remain default.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...