Jump to content
Mumble forums

RESOLVED [Help me !] Crash of Mumble on my new PC


kiss4u
 Share

Recommended Posts

Hi all,


I use a new gaming laptop last few weeks but, unfortunately, mumble does not work on it!


For several days, I try without success to operate Mumble on this new Windows7 64bit PC.


The program installation is done correctly and it starts well.


However, when I connect to a regular server, the program crash prompted systematically.

All other users can not hear me but they just see my avatar connect and disconnect immediately.

From my side, my Mumble interface still says I'm connected, but in reality it crashed: Some interface controls do not respond and if I try a disconnection/reconnection it stops working completely. Meanwhile, my CPU is still in work and I can not close Mumble program unless using the task manager.


I already tried versions 1.2.3a and 1.2.4bêta(Dev Snapshot). Between each test, I completely uninstall Mumble (including user and temporary files). I execute the program as an administrator and I have tested a lot of Windows compatibility mode (Vista / XP / etc). And all my drivers are up to day. But none of this works!


Please, help me if you can !


thanks

Edited by kiss4u
Link to comment
Share on other sites

Hello and thank you for your response.


At the time of installation I encounter an application error of mumble.exe.

The system tells me: "0x77e08dc9 instruction uses the memory address 0x00000014. The memory could not be in a written. Click OK to terminate the program."


However, if I do not care about this error, I can still enter the password and access to the Mumble server. It is from there that I met the crash problem described in the first post.


While I do not try to disconnect me, I can use the complete audio wizard and all parameter settings in their entirety. I still see my avatar as being connected but other users can not hear me and see me be disconnected.


If I try to disconnect, nothing happens and my avatar appears always on the server in terms of my interface (I can still use the audio wizard and settings). In addition, the server no communicates to me a disconnection message. If I try to reconnect anyway, I see the program is well crashed and mumble interface unresponsive. I have to close the program with the task manager.


Thank you for taking the time to read.

Link to comment
Share on other sites

RESOLVED

 

Looking through the forum I tried the solutions you propose.


I solved my problem by disabling QoS and forcing TCP mode (Setup> Settings> Network> Connection> Check the first box and uncheck the second)


Kissaki, thank you for your help, here and elsewhere, that allowed me to find the solution!

Link to comment
Share on other sites

  • Administrators

Rather than a good solution, those are means to test which part of your setup is wrong. :)


Using TCP only has drawbacks, mainly in latency.


If you would like to improve your setup, please check which of the two fixes your problem, or if you indeed need both.


If you problem exists with QoS enabled, but disappears with QoS disabled, you probably have a very bad router and/or network setup - which drops network packets with QoS (where it should actually prioritize them …).


If TCP-Mode fixes your problem, your network/router seems to block UDP packets. If you have control over your network, check some firewall settings. But really, blocking UDP should not happen, especially when TCP is allowed …

Link to comment
Share on other sites

Hello,


I carried out the checks. The problem is only related when QoS is actived. If TCP is checked or unchecked, it does not change.


But I do not understand where the problem may come with QoS. I have a pretty good and high-speed connection (real 30Mb/s Download & 0.99Mb/s Upload) and ping tests confirms the quality of my connection : http://www.pingtest.net/result/64323836.png


My Latop uses a Killer E2200 PCI-E Gigabit Ethernet Controller (NDIS 6.20) network card for LAN. I do not use the wifi connection.


On the Killer card, the Mumble application is permitted with the highest priority. On my firewall, Mumble also has all permissions.

Link to comment
Share on other sites

  • Administrators

Oh, killer card with driver with custom packet prioritisation? :)


Well, disable QoS and disable TCP mode again then, as a solution.


The problem is either your network cards driver, a router that connects your LAN (your PC) to the internet or other outwards networks, or your ISP (unlikely).

QoS is an extension of protocol. Some really bad router providers just fuck up big time and drop them, (because of) with a to them unknown protocol value.

Link to comment
Share on other sites

Oh, killer card with driver with custom packet prioritisation?

Yes that's right :p


The manufacturer has released a beta driver for the Killer card, I'll test it to see if it is indeed a problem of drivers.


My home network is built around a Netgear router (wifi, but not use for Mumble) and Netgear Powerline terminal.


By cons, the box provided by the ISP is an inefficient old model but it will be replaced by a new model towards the end of the summer.


Now, I must take the time to check the impact of each element one by one ... But I lean more to the Killer card driver, because on my old Latop and under the same conditions (network/connection) Mumble worked perfectly with these origins settings.


Thank you again for your invaluable help !

Link to comment
Share on other sites

  • 4 weeks later...

Hey Guys


I have been jumping around the forum and the web for a few days now trying to resolve this issues. This appears to be pretty simular to the problem i am having the same issue were I launch mumble and connect to the server and my avatar appears on the server but I am unable to move channel or interact with any members on the server I am told that my avatar stays in the lobby of the server connected for about 30secs or so then disconnects but on my end I am still connected to the server and unable to do anything. When I try to close mumble it hangs and I have to kill it in the task manager.


I have reinstalled the client a few times and no errors appear upon install and even did a complete system rebuild to see if that would fix the issue but sadly this didn’t fix it. Main difference between my problems and Kiss4u is that I am using a desktop build PC with on board motherboard sound card. This wasn’t a problem up to about 2-3 weeks ago when mumble worked fine without any issues.


I have also tried disabling QOS this allows me to move around the mumble channels and talk to other members on the server but does not allow me to hear anyone on the server(Audio Wizard runs fine without any errors). I have also tried disabling QOS and enabling TCP but I still receive the same issue of not being able to hear anyone but can move around channels.


Next thing I tried was installing mumble on my old laptop and connected to the server over my networks wireless (desktop connected via cable) with that this worked perfectly no issue at all QOS was enabled and everyone could hear me and I could hear them.


Anyone other tests or suggestions would be greatly received?


Thank you

Link to comment
Share on other sites

Try a server loopback (advanced settings) and see if you can hear yourself (with packets flowing through the server).

 

Hey Kissaki


Thank you for all your help in this matter I have now resolved my issue. Turns out that the mother board I am using (link below) has 2 network ports the one I had the network cable plugged into the bottom port I believe this may be an ILO port so not configured to run the same as a standard port anyway I switched the cable back over and all is back to normal . strange way to solve the problem but I guess I have learned to pay more attention when cleaning my machine and unplugging all the cables.


http://www.scan.co.uk/products/gigabyte-g1sniper-3-intel-z77-s-1155-ddr3-sata-iii-6gb-s-sata-raid-pcie30-d-sub-dp-dvi-hdmi-e-atx


Thanks again for all your help.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...