Jump to content
Mumble forums

Problems Installing Murmur/Mumble


chrison
 Share

Recommended Posts

Hi, all!


First, my system setup:


Computer: Dell Inspiron 1318 Laptop

O/S: Fedora 12 Linux 64-bit (kernel 2.6.32.11-99.fc12.x86_64)

Murmur/Mumble Version: 1.1.8 (obtained via yum to fedora repositories)

Speex Version: 1.2rc1

QT Version: 4.6.2


I have a couple of problems. First, when I start Murmur (murmurd -ini /etc/murmur/murmur.ini -fg -v), I get the following output to console:

 

Initializing settings from /etc/murmur/murmur.ini (basepath /etc/murmur)
ServerDB: Openend SQLite database /home/chrison/murmur.sqlite
Failed to register on DBus: org.freedesktop.DBus.Error.AccessDenied Connection ":1.81" is not allowed to own the service "net.sourceforge.mumble.murmur" due to security policies in the configuration file
OSInfo: Failed to execute lsb_release
1 => Server listening on port 64738
1 => Not registering server as public

 

I'm not sure how to fix the DBus error? I have read the wiki page on how to configure Murmur/DBus, and have setup the /etc/dbus-1/system.d/murmurd.conf file. Since I want to use the system DBus daemon, I also did a reboot. When I run "qdbus --system net.sourceforge.mumble.murmur /" I get "Service 'net.sourceforge.mumble.murmur' does not exist" for output, so obviously I'm missing something here.


Can someone tell me how I modify the Murmur and/or DBus configuration files so that it allows Murmur to connect and use DBus?


Second, I'm not sure what the "OSInfo" error message means? As anyone seen this and know how to fix it?


Finally, when I run Mumble and try to connect to Murmur using the SuperUser account and passord, it doesn't work. Murmur reports the following:

 

1 => <1:(-1)> New connection: 127.0.0.1:47897
1 => <1:(-1)> Connection closed: Error while reading: error:1408F044:SSL routines:SSL3_GET_RECORD:internal error

 

Does anyone know how to fix this one?


Thanks, in advance, for any help provided.


Regards,


Chris

Link to comment
Share on other sites

  • Administrators

Second, I'm not sure what the "OSInfo" error message means? As anyone seen this and know how to fix it?

I think that's a warning going on on fedora you can ignore. Not important.

 

1 => <1:(-1)> Connection closed: Error while reading: error:1408F044:SSL routines:SSL3_GET_RECORD:internal error

Can other ppl. connect?

Link to comment
Share on other sites

Hi, kissaki:


Thanks for the reply... MUCH appreciated!

 

Second, I'm not sure what the "OSInfo" error message means? As anyone seen this and know how to fix it?

I think that's a warning going on on fedora you can ignore. Not important.

 

Okay, thanks! I didn't think it was all that important, but asking doesn't hurt, eh? ;)

 

1 => <1:(-1)> Connection closed: Error while reading: error:1408F044:SSL routines:SSL3_GET_RECORD:internal error

Can other ppl. connect?

 

No. I have Murmur only looking at 127.0.0.1 and haven't yet created any accounts (I'm assuming the SuperUser account is hard coded?) so there's no way anyone else could even try to connect. I figured I'd get it going for Superuser at 127.0.0.1 and *then* configure user accounts and have Murmur listen to the outside world. Is that the "right" way to do things?


One of my "challenges" has been the lack of documentation on how to set things up. While there is "some" documentation, it isn't very detailed and there isn't much to help when things go wrong. For instance, the "SSL_routines:SSL3_GET_RECORD" error hints that this may be an SSL certificate problem (?) but all of the lines in the ini file related to SSL are commented out. There's nothing (that I could find?) that says SSL is required and, if so, how to do that. So, if SSL is optional and "turned off" how can I be getting an SSL error??? And, if SSL is mandatory and must be turned on, how do I do that???


Anyway, I'd be VERY thankful for any help you can provide so I can get this going... THANKS again!


Regards,


Chris

Link to comment
Share on other sites

  • Administrators

So, you plan to require users to have an account before they can connect?


SSL is always used. Connections are done with SSL for security reasons.

1 => <1:(-1)> New connection: 127.0.0.1:47897

1 => <1:(-1)> Connection closed: Error while reading: error:1408F044:SSL routines:SSL3_GET_RECORD:internal error

Did you try connecting not as SuperUser? With or without an account, doesn't matter.

Can you connect to other servers? Do you have a user-certificate set up (your client)? A custom one?


About the commented out SSL settings, you're talking about

#sslCert=
#sslKey=

right?

Those are not needed, murmur will automatically create certificates if you don't specify one.


I'd run it public even when setting it up.

Then you could also check if other ppl can connect. :)

Link to comment
Share on other sites

Hi, kissaki:

 

So, you plan to require users to have an account before they can connect?

 

Correct. Perhaps a bit more explanation of what I'm trying to do would be helpful...


I'm learning to fly a flight simulator... FlightGear... and have found a "virtual flight instructor" who's in Liverpool, UK (I'm in the States). FlightGear has dual control capability (i.e. I'm the pilot and the guy in Liverpool is the copilot and we can both see/control the aircraft). It also comes with a voice communication system (FGCom) where we can talk to each other as we're flying. The idea is that he "sits beside me" and helps me learn how to fly the plane properly.


The problem is that he can't get FGCom to work properly on his system. So, we tried using Skype instead of FGCom. Guess what? I can't get Skype to work properly on *my* system! :( We've tried dual-control just IM'ing each other using Skype, but that's awkward has hell.


Sooo... I'm hoping to get Mumble working so we can try that. In short, the "plan" is that there will only be two users connected to Murmur... my "instructor" in Liverpool and myself. The thought was that nobody else could get on because they wouldn't have an account and, of course, the server wouldn't be published (all the lines in the ini file about server registration are commented out), so that people wouldn't even know it's there.


So, if there's a way to do the above easily I'd appreciate knowing how.

 

SSL is always used. Connections are done with SSL for security reasons.

 

Oh! I didn't know that!

 

Did you try connecting not as SuperUser? With or without an account, doesn't matter.

 

Yes, I tried connecting using my own ("chrison") username, both with and without a password, and couldn't connect... same error message. :( Again, I haven't set it to listen to the outside world because my assumption is that if I can't connect locally then anyone "out there" isn't going to be able to connect either.

 

Can you connect to other servers?

 

After installing Mumble, I connected to a couple of servers on the internet (can't remember which ones) to see if it worked, but there wasn't anyone around at the time that I could talk to. So, yes I can connect to other servers, but I'm not sure if once connected I can communicate.


Btw, FGCom comes with an "echo channel" that is a server you can connect to and everything you say is echoed back to you for testing purposes. Is there a similar server for Mumble, or do I need to find an active server (with other people connected) to test Mumble?

 

Do you have a user-certificate set up (your client)? A custom one?

 

Uhhh.... No, not unless Mumble creates one on its own. Mumble was installed "out of the box" and I didn't change anything that I can remember. All I did was go through the audio setup wizard. If I need to create a user-certificate for Mumble, I'd appreciate some tips on how to do that, please.

 

About the commented out SSL settings, you're talking about

#sslCert=
#sslKey=

right?

 

Right, those are the ones.

 

Those are not needed, murmur will automatically create certificates if you don't specify one.

 

Oh! I didn't know that! :oops: That's information that would be helpful if it were added to the comments in the ini file (hint to developers!) ;)

 

I'd run it public even when setting it up. Then you could also check if other ppl can connect. :)

 

Okay, I'll give that a try in the next few days.


Thanks again for your help!


Regards,


Chris

Link to comment
Share on other sites

  • Administrators

Which version of Mumble?

On Fedora? Both Client and Server?

Murmur the same version as Mumble?

 

Btw, FGCom comes with an "echo channel" that is a server you can connect to and everything you say is echoed back to you for testing purposes. Is there a similar server for Mumble, or do I need to find an active server (with other people connected) to test Mumble?

 

In your settings, audio output section, there's a loopback section.

You can do a local as well as a server (if you're on one) loopback, add some delay, etc.

(Maybe you'll have to enable advanced settings, bottom left of your settings dialogue)

 

Do you have a user-certificate set up (your client)? A custom one?

 

Uhhh.... No, not unless Mumble creates one on its own. Mumble was installed "out of the box" and I didn't change anything that I can remember. All I did was go through the audio setup wizard. If I need to create a user-certificate for Mumble, I'd appreciate some tips on how to do that, please.

 

From Mumble 1.2 onwards after installing and running the first time the first wizard displayed will be one for a user certificate, the second one for audio setup.

But when you're able to connect to other servers, that shouldn't be the issue here.


Mh, SSL read error, maybe your fedora system isn't up to date enough or sth and can't understand some SSL things?…

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...