Jump to content
Mumble forums

I can't for the life of me host a server....


greggor01
 Share

Recommended Posts

I don't know if I'm doing something fundamentally wrong but I cannot get the server to run on my server here at home.


I've forwarded the port for UDP and TCP although I have had issues in that area with the verizon fios router that I am required to use.

I am running Windows Server 2008.

I am constantly getting the same error and here is my log output:


2010-04-21 18:51:00.642 Initializing settings from D:/Program Files (x86)/Mumble/murmur.ini (basepath D:/Program Files (x86)/Mumble)

2010-04-21 18:51:00.642 Binding to address (MY EXTERNAL IP ADDRESS) <- I removed it to protect the innocent! ;)

2010-04-21 18:51:00.644 SSL: Added CA certificates from system store 'Ca'

2010-04-21 18:51:00.648 SSL: Added CA certificates from system store 'Root'

2010-04-21 18:51:00.650 SSL: Added CA certificates from system store 'AuthRoot'

2010-04-21 18:51:00.655 ServerDB: Openend SQLite database D:/Program Files (x86)/Mumble/murmur.sqlite

2010-04-21 18:51:00.674 DBus registration succeeded

2010-04-21 18:51:00.675 MurmurIce: Endpoint "tcp -h 127.0.0.1 -p 6502" running

2010-04-21 18:51:00.675 Murmur 1.2.2 (1.2.2) running on Win: 6.1.7600.1: Booting servers

2010-04-21 18:51:00.791 1 => Server: TCP Listen on (MY EXTERNAL IP ADDRESS):64738 failed: The address is not available

2010-04-21 18:51:00.887 1 => Stopped


NOTE: I set the host=(MY EXTERNAL IP ADDRESS) in the murmur.ini file because I kept getting:

2010-04-21 19:14:28.158 1 => Server listening on 0.0.0.0:64738

2010-04-21 19:14:28.252 1 => Not registering server as public


NOTE: I am very technical.


Please HELP! :(

Link to comment
Share on other sites

  • Administrators

You cannot bind to your external address if you only "use" that over NAT. Either set the address to one of your computers real IPs or leave it alone (this will make murmur listen on all available addresses). If this is a machine in your home network it'll most probably only have one IP in any case.


About the not registering as public thing. You have to fill in all registerX variables in the config for the server to enlist itself in our public list. This has nothing to do with setting you IP, the messages just happen to be logged after each other.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...