Jump to content
Mumble forums

No Echo Cancellation on Mac?


ninfuzz
 Share

Recommended Posts

Hi all, I'd appreciate any help that folks could offer with regards to a problem I'm having with Mumble. Apologies in advance for my lack of technical savvy.


I have macbook pro, OSX 10.8.2. I recently downloaded Mumble so that I could use it in conjunction with playing an online game (Eve Online). When I run Mumble's Audio Tuning Wizard, at the Device Selection Screen I am unable to check the feature labeled "use echo cancellation"—it is simply greyed out. Moreover—and I suspect in connection to my inability to activate echo cancellation—any sound detected by my laptop's built in mic is replayed through the laptop speakers, which in turn is picked up by the mic and replayed, so on and so on, in a series of rather jarring screeches and wails. Under the pulldown menu for "Device" I have three options: (1) Default device; (2) Built-In Input; (3) BoomDevice (a 3rd party app I use to increase my laptop's otherwise paltry volume). None of these three options, when selected, allow me to activate the echo cancellation. Here's an example of what I encounter:


http://i.imgur.com/8I7zJ.png


Searching for solutions online turned up little help, with the exception of one brief forum exchange where someone associated with Mumble indicated that echo cancellation was not available on macs. Therefore, my questions are:


1) Is it correct that echo cancellation is not available for mac users? If this is not the case, then how I do to activate the feature?


2) If echo cancellation is indeed unavailable on macs, are there alternative solutions that I can use? Otherwise, it seems like I'm limited to using Mumble to recieve audio messages while forever muting my mic, lest I blast myself and those I'm speaking to with those awful feedback wails.


Any ideas?

Link to comment
Share on other sites

  • Administrators

There is currently no Echo Cancellation in the OS X client.


We've tried to use the VoiceProcessingIO built-in echo cancellation (which is what the Mumble for iOS), but it doesn't seem to work to well on OS X, at least it wasn't obvious how to get it to work the last time I tried.


I'm aware that this is still quite a big blocker for OS X users that don't use headsets, but unfortunately, that's how it is right now.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...