Jump to content
Mumble forums

[Solved] Mumble 1.2.3 crashing with Windows 7 64bit


soul2920
 Share

Recommended Posts

I've never had a problem with mumble before. However I purchased a Valkyrie CZ-17 BTS from Ibuypower and I can't get it to work for the life of me. The program immediately crashes upon trying to open it and allows me to send a crash report to Mumble. However the program will open after it does this. Then I find myself unable to connect to my server even though I can see my latency and the number of players on my server.


I've re-downloaded my audio drivers, checked for compatibility issues with the software and have lowered all firewalls while attempting to use the program. So either Mumble 1.2.3 is garbage or there is some hardcore incompatibility issues between the program and my computer's hardware. Using Realtek HD audio drivers.


I'm not an idiot and have already checked out the FAQ so if you reference it I'm going to rage on you. That FAQ was utterly worthless.


Edit: Initially it wouldn't even allow me to send an error report, I kept getting error 6.


Edit 2: I've tried snapshot downloads of 1.2.4 and it is having the exact same issue as 1.2.3. My other computer that is running Vista SP2 is running Mumble like a champ. This leads me to believe the issue is either a clash with Windows 7 or my Realtek HD audio drivers.


Edit 3: One time I got an error message saying that access was denied and that the overlay was the cause. I tried jacking with the overlay options and it did nothing for me.


Edit 4: After hours of testing I've narrowed the issue down to a Windows ntdll.dll file. Still not fixed though.


Would be great if someone from Mumble could get on this...

Edited by soul2920
Link to comment
Share on other sites

  • Administrators

Searching for *Valkyrie CZ-17 BTS*, it is a laptop!?


You said “I kept getting error 6”.

What kind of error was that? Did the mumble client start and it showed in the log messages? Or was it before any GUI showed up and a windows dialog that displayed it?


I’d also be interested in the kind of error message that suspected the overlay. What kind of message, who displayed it and what it said really.

You said you fiddled with the overlay settings. So I guess you also tried disabling it, then relaunching the client?

With the overlay disabled it really shouldn’t become active in any matter. And if your issue still exists then, it is not the overlay that’s causing it.


As you suspected the Realtek HD audio drivers, did you try uninstalling them?


Personally I can’t check the crashdumps being sent in.

Maybe one of the other devs can/will.


Where do you get the “ntdll” from?


Does the windows events and logs show anything useful/on the issue?

Link to comment
Share on other sites

All of the error messages came from the Mumble program. When it failed to send the Mumble Crash Report it was Mumble that said it was Error 6 and that I should contact a Mumble Developer about the situation. The only time Windows was involved was when it told me the Mumble program had become unresponsive or when I found the file clash via Event Viewer. I have pasted a copy of the log during the crash below. Also, it just BSOD'd my $2100 laptop while I was trying to get this information for you... I don't like it doing that so I'm not going to touch the program anymore until you've found a fix. I'd prefer my brand new hard drive didn't get trashed.


Via Event Viewer:


- System


- Provider


[ Name] Application Error


- EventID 1000


[ Qualifiers] 0


Level 2


Task 100


Keywords 0x80000000000000


- TimeCreated


[ SystemTime] 2012-10-27T23:56:39.000000000Z


EventRecordID 2356


Channel Application


Computer Zach-PC


Security



- EventData


mumble.exe

1.2.3.0

4d603982

ntdll.dll

6.1.7601.17725

4ec49b8f

c0000005

00038dc9

1600

01cdb49eb28653a8

C:\Program Files (x86)\Mumble\mumble.exe

C:\Windows\SysWOW64\ntdll.dll

f2c53b75-2091-11e2-871f-8c89a50473c0

Link to comment
Share on other sites

  • Administrators

You should be aware that if an application not running in kernel space (Mumble doesn't) can BSOD your computer then it's a driver issue. Sure. It is possible that we trigger the bug in the driver by using it in a special way but Mumble is not the root cause.


Neither Windows 7 64bit nor Realtek HD devices (if their drivers are up to date) should be a problem. Until I upgraded I used both myself. If you manage to launch Mumble try switching off "Quality Of Service" in the Network settings (check advanced) and see if that helps. Some broken network drivers out there are really allergic to it.


To look at your crash dump I need additional information to find it in our database:

* Comment/email used during submission

* Date of submission

* Exact mumble version (e.g. as shown by the about dialog)


Sorry for not being able to provide you with a straight up diagnosis / fix but you have to realize that pinpointing such issues remotely is not easy.

Link to comment
Share on other sites

Unchecking the Quality of Service allows me to connect to the server. Although now there is another issue. I cannot hear other users so there is something blocking data from the server. However, other users can still hear me and themselves. So the problem is definitely just within my system. I tried running it in compatibility mode like the FAQ stated and it had no effect. I have Mumble bypassing all of my firewalls so I'm thinking its definitely a driver issues, I've contacted my manufacturer and made sure all of my driver are fully updated. I don't know what else to do.


Edit: I've confirmed that the issue is my LAN driver, I can connect to Mumble without issue if I use my wifi card. I'll be contacting the manufacturer tomorrow to find another driver to use for LAN.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...