Jump to content
Mumble forums

Freezes on connect


zalvurek
 Share

Recommended Posts

I host a Murmur server so my friends and I can talk to each other while we play games. Last night/this morning (depending on view) before I went to bed (about 4am) it was working fine. While I was asleep my computer decided to restart to apply windows patches and when I woke up I had to start Murmur and Mumble back up again. However, when I started Mumble up and tried connecting to my server it just hung there unable to connect and the program stopped responding. I did notice that Mumble was updated because it noted it in the text area of the program.


I downloaded 1.2.2 (my previous version was 1.2.1) and have since installed it only to find that it did not fix the problem. I considered that uninstalling Mumble could have inadvertenly reblocked it on my firewall so I checked and fixed that but that didn't solve the issue either. I also considered that there could be something wrong with my server so I tried connecting to one of the public servers listed in the Mumble Server Connect window and the same thing happened. So my questions are: Why is it freezing while trying to connect? Why did this just start happening? How do I fix it?


I only really need that last question answered though, the others are just because I'm curious.


I'm using Windows 7 btw, if that helps.

Link to comment
Share on other sites

I just found a new symptom, when I try to connect and it freezes the program I lose connection to the steam community (friends list, etc.). The rest of my internet connection runs smoothly, because I'm still connected to everything else and I don't have any lag in Global Agenda.

Link to comment
Share on other sites

After I restarted and this problem came up it was the first thing I ran so I didn't have any games open at the time. One of the first things I did was turn off the overlay and positional audio when I got mumble and noticed them in game so they are still off (I rechecked). So this problem happens if I have a game running or not.

Link to comment
Share on other sites

I also had a freeze problem, when my USB headset wasn't recognized correctly by Win7 (but it was in the device list). So obviously Mumble tried to use the device, but got some kind of error. CPU load increased to 100% and I had to close Mumble through the task manager.


However replugging the headset solved my problem.

Link to comment
Share on other sites

So, I feel a little stupid because I hadn't considered/remembered this before but I checked the log for murmur to see what it said when I tried to connect and this is one of the attempts (underlined the problem line to make it more obvious):


2010-02-11 16:03:18.523 1 => <19:(-1)> New connection: (my ip and port here)

2010-02-11 16:03:18.523 Connection: Failed to add flow to QOS

2010-02-11 16:03:18.673 1 => <19:(-1)> Client version 1.2.2 (Win: 1.2.2)

2010-02-11 16:03:18.843 1 => Starting voice thread

2010-02-11 16:03:19.005 1 => <19:Zalvurek(1)> Authenticated

2010-02-11 16:04:07.947 1 => <19:Zalvurek(1)> Connection closed: The remote host closed the connection [1]

2010-02-11 16:04:08.063 1 => Ending voice thread


And while scanning the rest of the log I found this a few times when I tried connecting:


2010-02-10 17:37:19.217 1 => <6:(-1)> New connection: (my ip and port here)

2010-02-10 17:37:19.217 Connection: Failed to add flow to QOS

2010-02-10 17:37:19.350 1 => <6:(-1)> Connection closed: Error during SSL handshake: error:1408A10B:SSL routines:SSL3_GET_CLIENT_HELLO:wrong version number [13]


Any ideas why this might be happening?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...