Jump to content
Mumble forums

Linux 1.2.4 beta server QSQLITE error


luttgenj
 Share

Recommended Posts

Hi all,


Just decided to test out 1.2.4 beta, but I am having problems with the server. I downloaded and extracted 1.2.4-beta1-16-g2a469e8, then edited the mumble.ini to specify a different port than the production mumble server. When I try to run murmur.x86, I get this error:

 

ServerDB: Database driver QSQLITE not available

 

The server is Ubuntu 10.10, 64-bit. A quick Google search suggested that installing libqt4-sql-sqlite might help, but it didn't. Here are the log entries that are generated when I try to start murmur:

 

<W>2012-12-09 12:44:14.655 Initializing settings from /home/murmur/beta/murmur.ini (basepath /home/murmur/beta)
<W>2012-12-09 12:44:14.657 OpenSSL: OpenSSL 0.9.8o 01 Jun 2010
<C>2012-12-09 12:44:14.657 Successfully switched to uid 1001
<F>2012-12-09 12:44:14.657 ServerDB: Database driver QSQLITE not available

 

Anyone running the 1.2.4 beta server encounter this? Or have any thoughts on what to try?


Thanks

Link to comment
Share on other sites

  • Administrators

Thank you for reporting.

Someone else reported this earlier today, I think it was a debian system for him.


You downloaded the static binaries, right?


The static binaries do not seem to include qtsqlite, which it obviously should, as a self-sufficient binary.

We will look into it / I forwarded it.

Link to comment
Share on other sites

  • Administrators

[03:35:14] Kissaki: it does but there are at least 2 ways to get that message ...

[03:36:32] usually it's a permission problem. the server needs access to the server binary after dropping privileges, otherwise it's unable to load the sqlite driver from the binary

 

Does that help you?

Does fixing the permissions solve your problem?

Link to comment
Share on other sites

Thanks...I don't believe it's a permissions issue, but I double checked to be sure.


The directory and files have an owner and group of the username specified in murmur.ini:

 

uname=murmur

 

I also su'ed to murmur and tried to execute the binary - same result.


Here is the output of an ls -la of the directory where the static binary resides:

 

drwxr-xr-x 2 murmur murmur     4096 2012-12-10 16:51 .
drwxr-xr-x 8 murmur murmur     4096 2012-12-09 12:34 ..
-r--r--r-- 1 murmur murmur   319271 2012-12-05 08:01 CHANGES
-r--r--r-- 1 murmur murmur     8413 2012-12-05 08:01 icedemo.php
-r--r--r-- 1 murmur murmur    18011 2012-12-05 08:01 LICENSE
-r--r--r-- 1 murmur murmur    37482 2012-12-05 08:01 Murmur.ice
-rw-r--r-- 1 murmur murmur     5827 2012-12-10 16:51 murmur.ini
-rw-r--r-- 1 murmur murmur     5402 2012-12-09 12:35 murmur.ini.old
-rw-r--r-- 1 murmur murmur     5785 2012-12-09 12:35 murmur.ini.orig
-rw-rw---- 1 murmur murmur     3318 2012-12-10 16:51 murmur.log
-r-xr-xr-x 1 murmur murmur     8138 2012-12-05 08:01 murmur.pl
-rw-r----- 1 murmur murmur   456704 2012-12-09 12:34 murmur.sqlite
-r-xr-xr-x 1 murmur murmur 28498104 2012-12-05 08:01 murmur.x86
-r--r--r-- 1 murmur murmur     2791 2012-12-05 08:01 README
-r--r--r-- 1 murmur murmur     1402 2012-12-05 08:01 weblist.php
-r-xr-xr-x 1 murmur murmur     3317 2012-12-05 08:01 weblist.pl

Link to comment
Share on other sites

Ok, after doing a whole bunch of testing, I found something out!


The problem is related to the fact that I have ia32-libs installed on the system. That is screwing with something, but I am not sure exactly why or how.


I figured it out by installing a new clean vm of the same OS - and to my surprise, the binary executed. Then I started to slowly add things in that I configured in the production vm...and after adding ia32-libs, it gets broked.


Continuing research...

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...