Jump to content
Mumble forums

How to configure MySQL


gravitydk
 Share

Recommended Posts

I'm having trouble configuring Murmur to work with MySQL.

The server is operational with SQLite, but I want to change it to MySQL now so I can get MAP working.


Is it only the .ini settings that need to change, uncommenting and setting them to my MySQL server? Any other changes required?

Link to comment
Share on other sites

  • Administrators

Only the .ini settings. Be sure to read the comments around them and make sure all relevant entries are uncommented and set to the right value for your server.


Note however that we do not support tools that directly edit our database (we offer two separate interfaces for controlling the server).

Link to comment
Share on other sites

I uncommented them all, and get this error (within the ssh terminal) as shown after I do service mum start


I wasn't sure if the error means something really obvious to more experienced people, or not. I'm not a super Unix guy, so have been relying on more technical friends. I'm trying to work out of I can fix this by myself with some of you helpful chaps, but if not will get some paid help.

 

<W>2010-04-27 06:33:46.335 Initializing settings from /home/myaccountname/murmur/murmur.ini (basepath /home/myaccountname/murmur)
<W>2010-04-27 06:33:46.353 SSL: Added CA certificates from '/etc/pki/tls/certs/ca-bundle.crt'
[color=#FF0000]<F>2010-04-27 06:33:46.416 ServerDB: Failed initialization: Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2) QMYSQL: Unable to connect[/color]

 

I'm on a Centos 5.4 Dedicated server. MySQL version is 5.0.90-community; PHP I have is 5.2.13; Apache is 2.2.15.

I verified MySQL is on port 3306. I got the MySQL database settings right, I'm sure (double-checked they matched the MySQL database I'd set up). I obscured my account name in case it's a security issue (I wasn't sure).


I have these lines in murmur.ini:

 

# Path to database. If blank, will search for
# murmur.sqlite in default locations or create it if not found.
database= myaccountname_murmur
#database=
# If you wish to use something other than SQLite, you'll need to set the name
# of the database above, and also uncomment the below.
# Sticking with SQLite is strongly recommended, as it's the most well tested
# and by far the fastest solution.
#
dbDriver=QMYSQL
dbUsername=myaccountname_murmur
dbPassword=secretpassword
dbHost=localhost
dbPort=3306
dbPrefix=murmur_
dbOpts=

Link to comment
Share on other sites

My host gave me this answer after some digging.

Alright so it looks like this is an issue with where murmur expects things to

be. The error message:


2010-04-27 06:33:46.416 ServerDB: Failed initialization: Can't

connect to local MySQL server through socket

'/var/run/mysqld/mysqld.sock' (2) QMYSQL: Unable to connect


Says that it's looking for the mysql socket in /var/run/mysqld/mysqld.sock

-- The socket for mysql on your server (as far as I can tell) is located at :

/usr/local/lib/mysql.sock . I haven't had to deal with the mysql socket

much before, so this is a bit of new territory for me. I would ask the devs if

you can change where Murmur is looking for the sock

 

Any advice on that?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...