Jump to content
Mumble forums

Port troubles -- not sure if it's Ubuntu or Mumble


weirleader
 Share

Recommended Posts

I'm a brand-new Ubuntu (12.10) user and my first task was to try setting up a Mumble server. It seems to set up easily, but my client (on a Win7 machine on the same LAN) can SEE the server but can't JOIN the server.


For all I know I'm missing something obvious, but after scanning loads of posts I can't find anything that quite seems to help.

So, some details:


The server:

Murmur 1.2.4

listening on the default port: 64738


opened the port (64738) via ufw and confirmed

~$ sudo ufw verbose
Status: active

To                         Action      From
--                         ------      ----
64738                      ALLOW       Anywhere
64738                      ALLOW       Anywhere (v6)

 

then checked for listening ports

~$ netstat -ntlp
(Not all processes could be identified, non-owned process info
will not be shown, you would have to be root to see it all.)
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 127.0.0.1:631           0.0.0.0:*               LISTEN      -               
tcp        0      0 127.0.0.1:6502          0.0.0.0:*               LISTEN      -               
tcp        0      0 127.0.1.1:53            0.0.0.0:*               LISTEN      -               
tcp6       0      0 :::64738                :::*                    LISTEN      -  

 

but I'm not sure if the port should be listening on tcp vs tcp6; should that have any impact? If it does, I've no idea how to change that.


so then I run the client on my Win7 machine (I've tried both v1.2.3a and v1.2.4-beta) and I can see the server on the LAN:

  • ping is visible
  • hostname and port are visible
  • users correctly show 0/10 (as configured in mumble-server.ini)
  • version reads 1.2.4
  • but packet loss is generally between 75% and 100% loss

 

I can ping the server just fine, but nothing shows up in the mumble-server.log when I try to connect; so I'm guessing I'm not actually getting through when I try to connect. It tries for about 30 sec and then I get "Connection timed out."


here is my mumble-server.log file (after a server restart and an attempted login):

<W>2013-01-11 15:48:29.315 Initializing settings from /etc/mumble-server.ini (basepath /etc)
<W>2013-01-11 15:48:29.317 OpenSSL: OpenSSL 1.0.1c 10 May 2012
<W>2013-01-11 15:48:29.541 ServerDB: Opened SQLite database /var/lib/mumble-server/mumble-server.sqlite
<W>2013-01-11 15:48:29.562 DBus registration succeeded
<W>2013-01-11 15:48:29.570 MurmurIce: Endpoint "tcp -h 127.0.0.1 -p 6502" running
<W>2013-01-11 15:48:29.781 Murmur 1.2.4 (1.2.3-349-g315b5f5-2ubuntu2) running on X11: Ubuntu 12.10: Booting servers
<W>2013-01-11 15:48:30.042 1 => Server listening on [::]:64738
<W>2013-01-11 15:48:30.215 1 => Announcing server via bonjour
<W>2013-01-11 15:48:30.418 1 => Not registering server as public
<W>2013-01-11 15:48:30.419 Object::connect: No such slot MurmurDBus::userTextMessage(const User *, const TextMessage &)

 

If anybody out there has any ideas, I'd appreciate them.

Link to comment
Share on other sites

well you certainly got me moving in the right direction! QoS was already off (I'd tried toggling both it and Force TCP in the hopes that something good would shake out), but I just tried using a wired connection vs wireless and "magically" everything worked.


So my problem is 90% resolved. The only remaining issue is that I don't know enough to begin troubleshooting why my wireless is causing problems. I am clearly connecting to the internet, so it's not just connectivity. Any ideas why wireless functionality might differ? And how to attempt a fix?


Thank you!

Link to comment
Share on other sites

hmm, I have a strange update for you.


To try to make a long story short, my network configuration is such that I need a router in bridge mode to connect a couple of devices. That bridge router (running DD-WRT) also is configured to run a Virtual Interface. I can't even tell you why I did it (or what it really does), other than I was following some instructions for using a router as a bridge. I have no idea the pros/cons of a Virtual Interface being set up.


But here's the odd part. My Mumble server works when (a) wired to the bridge router, and (b) wirelessly connected to the Virtual Interface! I don't even understand that, because to me a Virtual Interface must be more complicated than connecting directly to the main router (provided by my ISP). And yet the wireless Virtual Interface works but not the wireless main network.


Any thoughts? Thanks!

Link to comment
Share on other sites

  • Administrators

UDP, in contrast to TCP, is not lossless.

I thus suspect that your wireless network is under heavy use, or other close wifis use the same frequencies, resulting in the same.

Not sure how the virtual interface comes in, or how I should understand your setup / how your setup is / how the vinterface is different from your normal wifi.

Link to comment
Share on other sites

  • Administrators

That sounds strange. Maybe some bad interaction between those specific wireless devices? Maybe the bridge router handles the packets slightly different? Hard to tell. Mumble might be triggering something there because it sends a lot more small packets than most other applications due to its low latency nature.

Link to comment
Share on other sites

Okay, I did some more moving of devices and I realize now that if I run the mumble-server on the FIOS router other devices connected to that can connect (but not those wired to the repeater bridge); and vice-versa, if it's wired to the repeater bridge then I'm cut off from devices connected to my FIOS router.


So maybe it's an issue with how the repeater bridge functions; although it's all one subnet (and everything sees each other and can ping each other and access the internet -- and even see the Mumble server!). That's deeply unsatisfying, as I really don't know how to begin figuring that out. :(


Guess I'll sit and stew on it for a while. Thanks, guys!

Link to comment
Share on other sites

Well, I learned something valuable about network architecture. I had my router set up as a repeater bridge. This did fine for getting me internet access, but apparently is not designed to support interaction between computers on either of the two routers being used. So although the subnet appeared to be the same, they were effectively isolated from each other.


Changing my setup so my router is now a Client turns my router into simply a fancy wireless receiver and bingo! I have connection with all other devices on the network.


Thanks for the help! I certainly had fun getting to understand this better.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...