Jump to content
Mumble forums

Sound conflict with Multiple Output devices


ttr0
 Share

Recommended Posts

Hello all -


I recently installed mumble to use with Team Fortress 2, but have run into a problem.


I run Mumble on Windows 7.


I run my game on a TV, but use headphones connected to my computer for sound. This is fine and dandy when only running the game application, and when i start mumble, the sound from mumble will come out of my headphones, while game volume comes out of my TV.


The issue is getting my game sound out of my headphones, instead of my TV. I have tried multiple fixes, including disabling my TV's sound, setting my headphones to default output device, but when i tried, all this does is disable sound from the game application completely.


Please help!

Link to comment
Share on other sites

  • Administrators

Rightclick on your Speakers icon in your sytem tray. Select Playback Devices.


Ensure that the device you want to play back audio on is set to the Default Device, and also the Default Communication Device. Same for 'Recording' (another tab in the same dialog).


If both are set to that, and you use the default devices in Mumble, you should be OK.


EDIT: The simple solution in your case it to ensure that your Default Playback device *isn't* your TV. If you set it to your headset, game sounds should play there.


EDIT 2: Sorry, I should read more carefully. I don't know why setting the Default Playback device to your headphones disables the game audio...


Does this happen when Mumble isn't running as well?

Link to comment
Share on other sites

Hey thanks for the prompt reply!


Yeah, I've been mucking around in that menu for the past few days....


I game on my laptop, so under the playback tab, I have 3 outputs with my tv connected: AMD HDMI Output, Speakers and headphones (my laptop), and Independent Headphones.


The problem is that I cant set the headphones are my default device. With all 3 outputs enabled, my HDMI output becomes default, when I disable that, my computer becomes default (sound still comes through TV). When I disable both the HDMI and my computer outputs, I lose sound for the application completely.


When I enable all 3 devices, I am unable to set my headphones as default. They are the default communication device, but even when i click the dropdown menu to set as default, it will not change; my comp remains default device.


EDIT: Its only when i run mumble, but the sound output problem carries over to other applications. IE if i have mumble and youtube running, youtube will come out of my tv.

Link to comment
Share on other sites

Hi again!


You mean through windows right? Neither of my sound outputs have exclusive mode application priority, and neither allows applications to take control of the device.


On a side note, for no apparent reason, after mucking with my settings yesterday, I was able to get both mumble and game sound through my headphones. However, today, upon restarting my computer, once again, I have the sound issue.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...