Jump to content
Mumble forums

Mumble translation is not working


opalium
 Share

Recommended Posts

Hello Mumblers!


Over the last few days I took the time to help Mumble by making a translation to Hebrew.

However, now that I am done, I am trying to load my translation into Mumble, but it doesn't seem to work.


What I did:

- Finished translating everything.

- File -> Release as... -> Saved the QM file as mumble_he.qm

- Placed the QM file in my Mumble directory.

- Started Mumble, changed the language setting to "System Default".

- Restarted Mumble.


However, the program stays in English, even after I restarted my entire system.

I looked at the list of languages in Mumble's settings but I couldn't find "he", even though it was there before. Maybe the language was deleted?


I am running Windows 8 Pro 64bit and using snapshot 1.2.4-rc1-6-g4dcd700 (which seems to be the latest one).


What can I do about this?


Thanks a lot,

~Opalium.

Link to comment
Share on other sites

  • Administrators

Hi. We temporarily disabled incomplete languages in preparation for the release (https://github.com/mumble-voip/mumble/commit/0ddb9224b6e1171abf11f516abcce3ed948721f6). Only built-in languages show up in the list.


If your system locale is set to hebrew and Mumble is set to "System Default" Mumble should pick up the translation file if it is in its application folder and named correctly. You can take a look at the %APPDATA%/Mumble/Console.txt and search for "Locale is" to see whether Mumble correctly identified the system locale as well as what locale it attempts to load. If it says x the translation file should be named mumble_x.qm.


If it still doesn't work send us the .ts + .qm and we'll try to figure out what's wrong. Stuff acting up is always a possibility ;)


Thanks for translating.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...