Url in welcome message

Mumble about Mumble

Url in welcome message

Postby monovitae » Sat Oct 19, 2013 6:20 pm

Not sure if this is a bug or if I just cant figure out how to format it properly. Given the keywords involved, my google foo is failing me.

mumble-server.ini
Code: Select all
welcometext="Welcome to <b>Server.com</b>. Enjoy your stay!                                                                                                                                             
<br>                                                                                                                                                                                                   
<A href="http://www.youtube.com/watch?v=93XiOIw&feature=player_embedded">Test</A>"


Upon restarting the server what shows up as the actual link that you can click on is this

http://www.youtube.com/watch?v

So it appears that the = in the url is causing some kind of conflict. I've tried escaping it with a \ but that just removes the = altogether.

Thoughts?
monovitae
 
Posts: 3
Joined: Sat Oct 19, 2013 6:14 pm

Re: Url in welcome message

Postby kissaki » Sat Oct 19, 2013 11:50 pm

Put it into a single line!?
Use \n and/or <br> to line break.
MumPI: Your Mumble Web Interface in PHP
User avatar
kissaki
Team member
Team member
 
Posts: 1292
Joined: Sat Jan 09, 2010 12:15 pm

Re: Url in welcome message

Postby monovitae » Sun Oct 20, 2013 12:16 am

Good suggestion but moving to one line both with and without the outermost quotes produces the same results as above.
monovitae
 
Posts: 3
Joined: Sat Oct 19, 2013 6:14 pm

Re: Url in welcome message

Postby kissaki » Sun Oct 20, 2013 8:30 am

Obviously, you have `"` in your text, canceling the quotation of the value.

Try using `'` instead.
Code: Select all
welcometext="Welcome to <b>Server.com</b>. Enjoy your stay!<br><A href='http://www.youtube.com/watch?v=93XiOIw&feature=player_embedded'>Test</A>"
MumPI: Your Mumble Web Interface in PHP
User avatar
kissaki
Team member
Team member
 
Posts: 1292
Joined: Sat Jan 09, 2010 12:15 pm

Re: Url in welcome message

Postby monovitae » Mon Oct 21, 2013 3:55 am

Single quotes wrapped in outer double quotes seems to work. Thanks for the help.
monovitae
 
Posts: 3
Joined: Sat Oct 19, 2013 6:14 pm


Return to General

Who is online

Users browsing this forum: No registered users and 4 guests

cron