Official Mumble VoIP Forums

Mumble Stable PPA for Ubuntu is 3 versions behind.

Mumble about Mumble
The stable PPA branch still serves version 1.2.12. Please update:

https://launchpad.net/~mumble/+archive/ubuntu/release

Thanks,
yeah I would like this updated too, I don't know whats going on.
1.2.15 is available in our PPA now.