Cannot turn off background noise cancellation - need to hear weak signals

It crashed, it is bugged, ...
Post Reply
Amateur_Radio_Steve
Posts: 2
Joined: 08 Sep 2020, 05:58

Cannot turn off background noise cancellation - need to hear weak signals

Post by Amateur_Radio_Steve »

Mumble is quite popular for providing low latency VOIP audio for connecting audio remotely to amateur (ham) radio stations. One problem - it seems impossible to turn off background noise cancellation. Unlike typical gamer, conference call user, where you WANT to drop out background noise, we value digging weak, distant signals out of the background static. Even with noise suppression turned off, you can immediately notice that Mumble tries to cancel out background static. The signal starts loud, as desired, then fades. Is there any way, either by setting, or programmatically, to turn off noise cancellation? Mumble is used to help provide amateur radio operators remote access their radios from cell phones or remote PC's - all for good, in my case, to help keep my elderly dad on the air, others for emergency access to their base radios, etc. Any help/suggestions would be greatly appreciated by the community. Thanks, Steve

User avatar
kissaki
Team member
Team member
Posts: 1479
Joined: 09 Jan 2010, 12:15
Contact:

Re: Cannot turn off background noise cancellation - need to hear weak signals

Post by kissaki »

I’m not sure about/familiar with the specifics, but I can imagine this being an audio codec thing as well. Not sure if Opus does provide a mode to try and keep even minuscule signals; it may.

Amateur_Radio_Steve
Posts: 2
Joined: 08 Sep 2020, 05:58

Re: Cannot turn off background noise cancellation - need to hear weak signals

Post by Amateur_Radio_Steve »

Thanks for your reply and idea. I will investigate Opus CODEC for seeing if we can turn off noise cancellation. It's the ONE thing that doesn't meet our amateur radio requirements, especially for Morse Code where we are often trying to catch tiny, distant signals.

Post Reply