Murmur 1.3 - Picture html welcometext

It crashed, it is bugged, ...
Post Reply
Puma
Posts: 4
Joined: 11 Sep 2019, 07:41

Murmur 1.3 - Picture html welcometext

Post by Puma »

Hello,

Since Murmur 1.3, picture in welcometext with html format isn't displayed.
(<a href=""><img src="......)

I tested with base64 encode, the problem is i can have text before the picture but text after base64 encode isn't displayed, and this increase my MySQL database moreover. I'm a hoster.

allowhtml is set on true on mumble-server.ini.

Do you have a solution or tips please ? Or is it a bug ?

Thanks.

User avatar
kissaki
Team member
Team member
Posts: 1431
Joined: 09 Jan 2010, 12:15
Contact:

Re: Murmur 1.3 - Picture html welcometext

Post by kissaki »

Loading of external images in messages was an undocumented (at least for client message sending) but working functionality before 1.3.0.

This was removed in 1.3.0 because of privacy concerns.

It is described in the features block in [User][Removed] Drop support for external images https://www.mumble.info/blog/mumble-1.3.0-release-announcement/#[user][removed]-drop-support-for-external-images.

I think we should make the breaking changes like this more visible though.

We want to revisit this in the future by implementing image proxying in the server that would prevent users from loading the web-hosted images directly.

For now, you can still embed base64 embedded images like before. When you send a message in the client and add an image it embeds it as well. You can copy it from there in the source tab if you have no other tools at hand.

Post Reply