Murmur SSL Handshake failed

It crashed, it is bugged, ...
Post Reply
Woelki
Posts: 5
Joined: 29 Sep 2019, 08:56

Murmur SSL Handshake failed

Post by Woelki »

Hi there,

after i updated my server Murmur suddenly started to close connections to the clients. Happens every full minute so mumble is completly unusable at the moment.

Mumble Server and Client are the latest version 1.3
Operating System: Arch Linux for Server Windows 10 1903 for all clients.
Network connection is absolutly stable not packet loss or anything.
Server is hosted at contabo.de has 8 Gigs of ram,4 Cores and 200gb of SSD Storage assigned (vps)

Tried reinstalling with different operating systems (FreeBSD 12.0, Ubuntu 19.04, Fedora 30)

All of them produce the same error:

<22:SuperUser(0)> Connection closed: Error while reading: error:140E0197:SSL routines:SSL_shutdown:shutdown while in init [20]

Any ideas why this happens?

User avatar
kissaki
Team member
Team member
Posts: 1479
Joined: 09 Jan 2010, 12:15
Contact:

Re: Murmur SSL Handshake failed

Post by kissaki »

You say closes connection, but from the log message I see it fails to establish a connection. So people are unable to connect now?

Did you change some of the ssl configuration of the server?
https://wiki.mumble.info/wiki/Murmur.ini#sslCiphers

Woelki
Posts: 5
Joined: 29 Sep 2019, 08:56

Re: Murmur SSL Handshake failed

Post by Woelki »

They can connect but get kicked after a minute. Within this minute voicechat and everything works fine. But the constant reconnects are a bit annoying

oh and no i did not touch anything from ssl

i installed the os then murmur/mumble-server set the super user password and started it. Like i always did before (been using mumble for quite a while)

As i said it worked fine before. Then it didn't. Don't know why

User avatar
kissaki
Team member
Team member
Posts: 1479
Joined: 09 Jan 2010, 12:15
Contact:

Re: Murmur SSL Handshake failed

Post by kissaki »

Does this happen for some people, or all people?

If some, what versions are they connecting with?

Woelki
Posts: 5
Joined: 29 Sep 2019, 08:56

Re: Murmur SSL Handshake failed

Post by Woelki »

it happens to everybody who connects

they all have the latest client installed at least they say so

Zing
Posts: 10
Joined: 21 Sep 2019, 22:59

Re: Murmur SSL Handshake failed

Post by Zing »

Is everybody on the same platform? E.g Windows.

Woelki
Posts: 5
Joined: 29 Sep 2019, 08:56

Re: Murmur SSL Handshake failed

Post by Woelki »

i use linux at home (Arch with KDE) everybody else runs windows 10 1903

Zing
Posts: 10
Joined: 21 Sep 2019, 22:59

Re: Murmur SSL Handshake failed

Post by Zing »

I'm going to assume it is a server issue. How long have you had this server? Maybe the cert has expired?

Woelki
Posts: 5
Joined: 29 Sep 2019, 08:56

Re: Murmur SSL Handshake failed

Post by Woelki »

I reinstalled severalt times so it was always new certificates from murmur.

But the problem disappeared out of the sudden. I suppose my hosting provider had issues in some way.

Zing
Posts: 10
Joined: 21 Sep 2019, 22:59

Re: Murmur SSL Handshake failed

Post by Zing »

Glad to hear it somehow fixed.

Post Reply