HTML messages documentation

How to do...

HTML messages documentation

Postby Delzur » Fri Sep 12, 2014 9:55 am

Hello,

I am trying to make nice HTML messages but I have many trouble doing it.
Mumble automatically transform, add and removes css properties.

For exemple, it always add <p>, removes <center> and "text-align:center;" (I really don't succeed on centring something !)

I did not find any documentation stating what tags are accepted, and how Mumble handles formatting.
Did I miss it, does it exist ?
Delzur
 
Posts: 4
Joined: Fri Sep 12, 2014 9:49 am

Re: HTML messages documentation

Postby natenom » Fri Sep 12, 2014 10:02 am

Mumble supports a subset of HTML and CSS, see here.
User avatar
natenom
Team member
Team member
 
Posts: 79
Joined: Wed Sep 23, 2009 11:40 pm
Location: Germany

Re: HTML messages documentation

Postby Delzur » Fri Sep 12, 2014 10:24 am

Nice thanks for the link, I did not find it in the wiki.

I see that <center> should be supported, but I can't get it to work. I don't have my exact layout here but it is close to this :

Code: Select all
<table>
 <tr>
  <td colspan="2">
   <center>
    Hello
   </center>
  </td>
 </tr>
 <tr>
  <td>
   Hi, i'm longer
  </td>
  <td>
   than the "Hello" message
  </td>
 </tr>
</table>


And hello isn't centred. Funny thing is, when I paste this in the source tab and click the tab message, "Hello" is centred. Then if I click source again, the <center> tag has disappeared. And whenever I send it, it is not centred.

Any clue ?

I'll post more details (with screen captures) tonight when I get home. I'll also try the <p align="center"></p> because I never did (and just discovered it on the doc you gave me)
Delzur
 
Posts: 4
Joined: Fri Sep 12, 2014 9:49 am

Re: HTML messages documentation

Postby Lindee » Fri Sep 19, 2014 12:53 pm

are you putting this into murmur.ini or do you have a web interface you are editing this in?
Lindee
 
Posts: 83
Joined: Fri Sep 19, 2014 12:20 pm

Re: HTML messages documentation

Postby jidea8 » Fri Sep 19, 2014 3:47 pm

neither webinterface, neither murmur.ini.
it's for editing user's or groups 's comments.
i try and he is right. Center is kicked after validation. some css spec are added. but text is no more centered.
jidea8
 
Posts: 9
Joined: Sat Sep 13, 2014 5:30 pm

Re: HTML messages documentation

Postby Lindee » Fri Sep 19, 2014 4:45 pm

Did you set "allowhtml=true" in the .ini file?
Lindee
 
Posts: 83
Joined: Fri Sep 19, 2014 12:20 pm

Re: HTML messages documentation

Postby Delzur » Thu Sep 25, 2014 9:34 am

Hello,

I'm talking about sending a message to a channel using mumble user interface. Of course as jidea8 states, it's the same for comments.

To answer Lindee :

Code: Select all
root@-----:~# grep html /etc/mumble-server.ini
allowhtml=true


So yes it is activated. I can successfully embed images to messages and the <table> also works fine. The only problem is with centering.

I could not give the examples I promised but I'll try to do it tonight or during the week end so I make my case clearer
Delzur
 
Posts: 4
Joined: Fri Sep 12, 2014 9:49 am

Re: HTML messages documentation

Postby Delzur » Sat Sep 27, 2014 3:04 pm

Hi
I have taken some screenshots to better explain the issue I'm experiencing with centering.
First, here is the sample text used throughout this test :

Code: Select all
<br/>
Hello normal
<br/>
<center>Hello centered</center>


First step, I enter this as the source text for a message to a channel
Image

Next, I click on the preview tab to see how it will get rendered
Image

The result is good. However it's kind of a lie. If I send the message, here is the reality
Image

And you can see it's not centered at all.
As a side note, if I click on source again instead of sending, you can notice that mumble edited my html
Image

And if I click again on preview, it's still centered...
Image

So there seem to be an issue here. What is the way to get <center> working ?
Delzur
 
Posts: 4
Joined: Fri Sep 12, 2014 9:49 am

Re: HTML messages documentation

Postby kissaki » Fri Oct 03, 2014 12:55 pm

It that does not work, and it inadequately shows a different preview, I guess it just does not work.
That could be considered a bug. Did you check for existing bug tickets?
MumPI: Your Mumble Web Interface in PHP
User avatar
kissaki
Team member
Team member
 
Posts: 1292
Joined: Sat Jan 09, 2010 12:15 pm


Return to Usage

Who is online

Users browsing this forum: No registered users and 3 guests

cron