Official Mumble VoIP Forums

Mumble & Ice [No connection ?]

How to do...
Hi !

So first, sorry for my english, i'm a french little guy ^^ .

I try to make a link between my Mumble server and a PHP page for have a list a channel and player.

So i've read the wiki about Ice and PHP, and the extension look correctly installed.

I download the page "weblist.php" and upload it on my server.

This is the result, and it's don't looks ok :P

Here's a c/p of the error:

Code: Select all

Ice_UnknownLocalException Object ( [unknown] => Network.cpp:1220: Ice::ConnectionRefusedException: connection refused: Connection refused [message:protected] => [string:private] => [code:protected] => 0 [file:protected] => /var/www/test/weblist.php [line:protected] => 12 [trace:private] => Array ( [0] => Array ( [file] => /var/www/test/weblist.php [line] => 12 [function] => ice_checkedCast [class] => Ice_ObjectPrx [type] => ->  [args] => Array ( [0] => ::Murmur::Meta ) ) ) ) 
My server run on Ubuntu, and this is the pieces of my murmur.ini about Ice:

Code: Select all

# Path to database. If blank, will search for
# murmur.sqlite in default locations or create it if not found.
database=mumble

# If you wish to use something other than SQLite, you'll need to set the name
# of the database above, and also uncomment the below.
# Sticking with SQLite is strongly recommended, as it's the most well tested
# and by far the fastest solution.
#
dbDriver=QMYSQL
dbUsername=root
dbPassword=THISISSPARTAANDIDONTGIVEUMYPASSWORD§§§§
dbHost=localhost
#dbPort=
dbPrefix=murmur_
#dbOpts=

# Murmur defaults to not using D-Bus. If you wish to use dbus, which is one of the
# RPC methods available in murmur, please specify so here.
#
dbus=session

# Alternate service name. Only use if you are running distinct
# murmurd processes connected to the same D-Bus daemon.
#dbusservice=net.sourceforge.mumble.murmur

# If you want to use ZeroC ICE to communicate with Murmur, you need
# to specify the endpoint to use. Since there is no authentication
# with ICE, you should only use it if you trust all the users who have
# shell access to your machine.
# Please see the ICE documentation on how to specify endpoints.
ice="tcp -h 127.0.0.1 -p 6502"
U can also find the result of a phpinfo(): HERE

Thanks in advance for you'r help ;)
Are you sure murmur is running and using the right configuration? You should also check whether port 6502 is actually open.

As far as I can tell, my experience with Ice and PHP is very limited, your PHP configuration looks fine.
My mumble is running (it's the server of my team, it's a required ^^ ), and i have no port firewall, so he's necessarily open :) .

(Thank for you'r answer)
Well. That doesn't really tell you if you loaded the right configuration and whether Ice is actually listening where weblist expects it to be.

Check whether the port shows up if you do a

Code: Select all

netstat -l | grep 6502
to make sure it is actually open.
When i enter you'r command, the _ begin to blink, and nothing happend, it's normal ?

EDIT: I don't know if it's normal, so i've try something else:
lsof -i :6502

And the result:
Image

EDIT2: Finally, i've let it run the all night, and she finally give me a response:
Image
I keep having trouble with ICE too. It seams I do suck on that matter in a noobish way.. But can you post your apache setting where you told apache to use the mumur.ice ?
I've put:
extension = IcePHP.so
ice.slice = /srv/mumble/Murmur.ice
into "IcePHP.ini" in /etc/php5/conf.d

i've also put in into my php.ini just in case :) .
Sorry for the double post, but they are some changes :) .

The port into my .php was wrong, but now, i have an other error, u can see it here: HERE

He find the server name, but not the rest... how to do ? :)
Is the web server and murmur server on the same computer?
If so and your web site is hosted out of /var/www . You would then type:

Code: Select all

sudo ln -s /usr/share/mumble-server-web/www/ /var/www/mumble
and get http://ryry.mine.nu/mumble/

Also did you

Code: Select all

sudo apt-get install mumble-server-web
to install mumble?
There's no error on the page linked.
Did you solve your problem?