Help with MuMo?

Ice/DBus, Web-Interfaces, Management tools

Help with MuMo?

Postby ealcott » Sat Apr 18, 2015 1:36 am

Im not sure were to put this but im trying to install mumo on a brand new debian server.

I have mumble installed along with PHP5, Ice, apache2, and python.

If i check the mumble-server log it is connecting with Ice and i can see the Ice version on the PHPinfo page.

I am following the instructions here.

when i get to setp 7 and actually run the mumo script i get the following message.

Code: Select all
Traceback (most recent call last):
  File "", line 34, in <module>
    import Ice
ImportError: No module named Ice

Anyone have any ideas, im new to linux and really to most of this so any help is greatly appreciated.

Also i am looking for a good web GUI for mumble server administration (hence the php installation) if anyone knows of a good one.

Posts: 4
Joined: Sat Apr 18, 2015 1:27 am

Re: Help with MuMo?

Postby fwaggle » Sat Apr 18, 2015 4:25 am

Did you install python-zeroc-ice?

Note that Ice is segregated by language, so it working in PHP is not good enough to indicate that all the packages are installed for Python.
Full disclosure: I used to run a commercial Mumble host, and my opinions do not reflect the opinions of the Mumble project.
Avatar is stolen from here
User avatar
Team member
Team member
Posts: 220
Joined: Tue Oct 06, 2009 10:40 pm
Location: Australia

Re: Help with MuMo?

Postby ealcott » Sat Apr 18, 2015 5:28 am

I ran the command from the article i posted.

apt-get install git-core python-zeroc-ice python-daemon

so i think that means i did install it?

Posts: 4
Joined: Sat Apr 18, 2015 1:27 am

Re: Help with MuMo?

Postby kissaki » Sat Apr 18, 2015 6:00 am

The include path in use when executing does not seem to be correct.

Check where the python-zeroc-ice package installs files to, specifically the Ice file/folder.
Then check where to put the include path.
MumPI: Your Mumble Web Interface in PHP
User avatar
Team member
Team member
Posts: 1293
Joined: Sat Jan 09, 2010 12:15 pm

Re: Help with MuMo?

Postby ealcott » Sat Apr 18, 2015 6:04 pm

I've been messing around with this.

I wasn't able to find the location of ICE and even re installed it trying to find where the files got unpacked to no luck. But then i looked at the instructions i linked above and wondered why i needed another user for all the mumo stuff so i just tried to run the script with my root and it seems to get further . . .

Now im not getting an import ice error but am getting this error.

-! 04/18/15 17:50:20.625 warning: unknown property: `Ice.Default.EncodingVersion'

and here is the block of code from the

Code: Select all
    #--- Moderator implementation
    #    All of this has to go in here so we can correctly daemonize the tool
    #    without loosing the file descriptors opened by the Ice module

    debug('Initializing Ice')
    initdata = Ice.InitializationData() = Ice.createProperties([],
    for prop, val in cfg.iceraw:, val)'Ice.ImplicitContext', 'Shared')'Ice.Default.EncodingVersion', '1.0')
    initdata.logger = CustomLogger()

    ice = Ice.initialize(initdata)
    prxstr = 'Meta:tcp -h %s -p %d' % (,
    prx = ice.stringToProxy(prxstr)

    if not

Posts: 4
Joined: Sat Apr 18, 2015 1:27 am

Re: Help with MuMo?

Postby ealcott » Tue Apr 21, 2015 4:27 am

I had a buddy help me get things going.

We had everythign working fine then all of a sudden we get this error in the mumo.log file.

Code: Select all
2015-04-21 04:15:20,755 INFO idlemove 565s > 60s: State transition for user TheRev (51/-1) from mute False -> True / deaf False -> False | channel 5 -> 20 on server 1
Exception in thread Thread-29:
Traceback (most recent call last):
  File "/usr/lib/python2.7/", line 552, in __bootstrap_inner
  File "/usr/lib/python2.7/", line 760, in run
    self.function(*self.args, **self.kwargs)
  File "modules/", line 109, in handleIdleMove
    self.UpdateUserAutoAway(server, user)
  File "modules/", line 188, in UpdateUserAutoAway
  File "/tmp/", line 1908, in setState
InvalidChannelException: exception ::Murmur::InvalidChannelException

It looks like the script is running and firing and when it tried to move a user it then throws this exception. I noted it says invalid channel but i checked and in the idlemove.ini we have it set to move users to channel 20 which is what the position of our AFK channel shows in mumble.

Anyone have any ideas?

Posts: 4
Joined: Sat Apr 18, 2015 1:27 am

Return to Scripting

Who is online

Users browsing this forum: No registered users and 1 guest