Official Mumble VoIP Forums

Freezes on connect

It crashed, it is bugged, ...
I host a Murmur server so my friends and I can talk to each other while we play games. Last night/this morning (depending on view) before I went to bed (about 4am) it was working fine. While I was asleep my computer decided to restart to apply windows patches and when I woke up I had to start Murmur and Mumble back up again. However, when I started Mumble up and tried connecting to my server it just hung there unable to connect and the program stopped responding. I did notice that Mumble was updated because it noted it in the text area of the program.

I downloaded 1.2.2 (my previous version was 1.2.1) and have since installed it only to find that it did not fix the problem. I considered that uninstalling Mumble could have inadvertenly reblocked it on my firewall so I checked and fixed that but that didn't solve the issue either. I also considered that there could be something wrong with my server so I tried connecting to one of the public servers listed in the Mumble Server Connect window and the same thing happened. So my questions are: Why is it freezing while trying to connect? Why did this just start happening? How do I fix it?

I only really need that last question answered though, the others are just because I'm curious.

I'm using Windows 7 btw, if that helps.
It's a bit unresponsive when updating plugins for me, but that's even before I can connect to a server.
After it did update the plugins it works fine again. (it tells me "updated and moved to folder…"
I just found a new symptom, when I try to connect and it freezes the program I lose connection to the steam community (friends list, etc.). The rest of my internet connection runs smoothly, because I'm still connected to everything else and I don't have any lag in Global Agenda.
So you're also ingame?
Try to disable your overlay and positional audio before connecting.
Also exit mumble and start it again before trying to make sure settings are saved.
After I restarted and this problem came up it was the first thing I ran so I didn't have any games open at the time. One of the first things I did was turn off the overlay and positional audio when I got mumble and noticed them in game so they are still off (I rechecked). So this problem happens if I have a game running or not.
I also had a freeze problem, when my USB headset wasn't recognized correctly by Win7 (but it was in the device list). So obviously Mumble tried to use the device, but got some kind of error. CPU load increased to 100% and I had to close Mumble through the task manager.

However replugging the headset solved my problem.
I don't think this is the case because I can talk through my headset in games and while Mumble is frozen it only uses up 11-12% of my cpu. I tried replugging in my headset anyway and it didn't fix it.

But thanks for the idea.
So, I feel a little stupid because I hadn't considered/remembered this before but I checked the log for murmur to see what it said when I tried to connect and this is one of the attempts (underlined the problem line to make it more obvious):

<W>2010-02-11 16:03:18.523 1 => <19:(-1)> New connection: (my ip and port here)
<W>2010-02-11 16:03:18.523 Connection: Failed to add flow to QOS
<W>2010-02-11 16:03:18.673 1 => <19:(-1)> Client version 1.2.2 (Win: 1.2.2)
<W>2010-02-11 16:03:18.843 1 => Starting voice thread
<W>2010-02-11 16:03:19.005 1 => <19:Zalvurek(1)> Authenticated
<W>2010-02-11 16:04:07.947 1 => <19:Zalvurek(1)> Connection closed: The remote host closed the connection [1]
<W>2010-02-11 16:04:08.063 1 => Ending voice thread

And while scanning the rest of the log I found this a few times when I tried connecting:

<W>2010-02-10 17:37:19.217 1 => <6:(-1)> New connection: (my ip and port here)
<W>2010-02-10 17:37:19.217 Connection: Failed to add flow to QOS
<W>2010-02-10 17:37:19.350 1 => <6:(-1)> Connection closed: Error during SSL handshake: error:1408A10B:SSL routines:SSL3_GET_CLIENT_HELLO:wrong version number [13]

Any ideas why this might be happening?
Disable QOS in your settings.
It's in the network tab and you need to enable advanced options, if you haven't already.
Seems your router can't take it or sth.
Yeah that let me connect.

I'm still curious why it suddenly doesn't work since I've always had that on, I don't have control over my router but oh well, I guess I'll deal.