Official Mumble VoIP Forums

Unable to interact with Mumble after mute / unmute quickly

It crashed, it is bugged, ...
Hello guys,

I hope your doing alright. I encounter a rather simple bug (or some kind of "anti-flood" feature). I often mute / unmute myself pretty quickly (like during 1 second).
After doing a quick mute-unmute, I'm not able to do anything. I can still hear my mates but nothing else.


Step to reproduce :
1. / Press as fast as possible the "mute" button (like 10 times).

After this, you can't do anything, no unmute, no change room.

If this is a feature, is there any way to turn it off ?

Thanks.
Hello JMax,

yes, that is a feature. It is server side rate limiting.
There is a cooldown period once you hit it. You should still be able to talk though, if you are unmuted.

See the messageburst and messagelimit config options of the server.
https://github.com/mumble-voip/mumble/blob/79435e64739514e11868a93b827a52cf1484a128/scripts/murmur.ini#L139-L149
kissaki wrote:
05 Oct 2019, 09:23
See the messageburst and messagelimit config options of the server.
https://github.com/mumble-voip/mumble/blob/79435e64739514e11868a93b827a52cf1484a128/scripts/murmur.ini#L139-L149
Hell yeah, you're right. I had an old mumble-server version and ended up doing a full upgrade from "jessie" to "buster".

I confirm that once I update the package mumble-server to 1.3.0~git20190125.440b173+dfsg-2 and change the value of messageburst and messagelimit to 5000, it solved everything.

I can finally spam the mute/unmute button. \o/

Btw I think it solve the following issue :https://github.com/mumble-voip/mumble/issues/3724

Thank you for the help kissaki, beers on me.
Mumble.png
Mumble.png (22.7 KiB) Viewed 69 times
Just beware of that these limits are there for a reason; to prevent DoS flooding. :)

If you keep that in mind, changing them is fine of course.

Thank you! ;-)